I have multiple IIS7 websites hanging off 1 IP, using different ports.

All three sites use Z.A.B.C:XX, where XX is {100, 200, 300} *

There's no web.config settings not making :300 not work, the bindings are set ok. I can even change the ports so 200 becomes 300, but the original 300 still doesn't work. They are all shown by IP, so it's not DNS. There's no SSL setting differences between them. I can't see anything in metabase.xml that would make one behave differently to another.

Are there any other settings in IIS7 that I might not be finding, that would fix the issue?

* not the real values.


The website being hosted, no matter the port, always returns 500 errors. This has been working in the last few days, tempted to try rolling back the website from backups, see if it's anything to do with that. Because I'm sure as heck that it's nothing in the IIS setting side.


have you ruled out the possibilty the actual website could be at fault? What I mean is this app running at xxx:300, change it's listening port to 200 or ANY other for that matter and try again. This will allow you to test whether it is actually port 300 or something wrong with the site itself.

Also another program may have port 300 in use so you can't assign it to your website. Try this to find what program is using port 300:

Open a command prompt and type: netstat -ano | find "300"

netstat -ano lists all ports in use. Adding the find on the end filters it to display only results with 300 in it. You are looking for a line that says or yourIP:300. On this line to the far right will be a number, this is the process ID (program) that is using this port. Open task manager, go to View > select column. tick the box "PID (Process ID). ok the box, now click the processes tab and find that ID in the PID column. This will tell you what program is using that port.

Take a look here for your 500 error codes http://support.microsoft.com/kb/943891. Anything look familiar?

  • The PID using that port just pointing to "System". As in "NT Kernel & System". – glasnt Jun 22 '11 at 0:03
  • hmm, that means IIS is using it. Did you try chaning the ports as I mentioned to see if the issue is the website itself? – Mucker Jun 22 '11 at 8:01
  • that was one of the first things I did. It's a problem with the settings of the website. The originally :200 site can work on :300 ok, but the original :300 doesn't work on any port. – glasnt Jun 23 '11 at 4:55
  • @glassnt, you never said this in your OP but I can see it has now been editted to identify this. Well this means that it has nothing to do with ports. Your problem is the website itself. What is different about this site to say one that works? Also check my update above on my answer about 500 errors – Mucker Jun 23 '11 at 12:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.