Our (active directory, windows-server-based) intranet used to be called "intranet", and DNS worked fine for windows machines and iPads/Android devices.

We have changed it to be "apps.intranet", and it still works for windows machines, but no longer for iPads/Android devices.

I think this is because out windows clients are configured to append .company.com when searching DNS, to make it a fully qualified lookup (this search suffix list is pushed to the PCs via AD group policies).

I must admit, though, I don't know why it worked with just "intranet"!

Does anyone know if it's possible to get DNS to "tell" the iPads/Android devices to append .company.com ... or how we can make it work some other way (but still using the multi-label, non-qualified DNS names) ?



Take a look at your DHCP server, are you supplying the option for a search suffix to your scopes?

  • This is correct. You can't do this from your DNS servers, you have to add "search domains" or "suffixes" to the clients, which can be done via DHCP. – mfinni Jun 21 '11 at 15:33
  • Ok, thanks. Well, yes I think this is working ok. Our wireless router has the "domain" entered, and when I connect a windows laptop, and do ipconfig /all, I can see the DNS search suffix list is "company.com"... so, I don't know why the iPad/Android are having a problem - is it something to do with the "spec"? Could it be that by introducing the "." the iPad thinks it should now be fully qualified? – Mark Jun 21 '11 at 16:16
  • why not just start referencing everything by FQDN? – SpacemanSpiff Jun 21 '11 at 16:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.