I'm running Vmware ESX 4.1 and I have a development VM that I recently upgraded from Ubuntu 10.04 to 11.04. Then I tried to re-install VMware Tools and some of the modules gave me an error and would not compile. As a result I'm having problems with backing up this virtual machine now and I suspect VMware tools is the reason. I installed latest patches for VMware host, that included an update to VMware Tools (v8.3.7 build-381511) but I'm still getting the same error.

The error I'm getting is like this:

/tmp/vmware-root/modules/vmhgfs-only/super.c:73:4: error: unknown field \u2018clear_inode\u2019 specified in initializer
make[2]: *** [/tmp/vmware-root/modules/vmhgfs-only/super.o] Error 1
make[1]: *** [_module_/tmp/vmware-root/modules/vmhgfs-only] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.38-8-generic'
make: *** [vmhgfs.ko] Error 2
make: Leaving directory `/tmp/vmware-root/modules/vmhgfs-only'

and also this:

/tmp/vmware-root/modules/vmci-only/vmci_drv.c:91:4: error: unknown field \u2018ioctl\u2019 specified in initializer
/tmp/vmware-root/modules/vmci-only/vmci_drv.c:91:4: warning: initialization from incompatible pointer type
/tmp/vmware-root/modules/vmci-only/vmci_drv.c: In function \u2018vmci_init\u2019:
/tmp/vmware-root/modules/vmci-only/vmci_drv.c:151:4: error: implicit declaration of function \u2018init_MUTEX\u2019
make[2]: *** [/tmp/vmware-root/modules/vmci-only/vmci_drv.o] Error 1
make[1]: *** [_module_/tmp/vmware-root/modules/vmci-only] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.38-8-generic'
make: *** [vmci.ko] Error 2
make: Leaving directory `/tmp/vmware-root/modules/vmci-only'

Any ideas?


My guess would be that you have the wrong version of the kernel headers. Unless you need some specific feature that is only available in the version of vmware tools you are trying to build (hint: You probably don't) you can save yourself a lot of pain by removing the hand-installed version and use the open-vm-tools package in ubuntu:

sudo aptitude install linux-headers-virtual open-vm-dkms open-vm-tools

It is also possible to pull the latest version of the tools directly from vmware, but then you need to mess a little with apt:

apt-add-repository 'deb http://packages.vmware.com/tools/esx/4.1latest/ubuntu natty main restricted'
wget http://packages.vmware.com/tools/VMWARE-PACKAGING-GPG-KEY.pub -q -O- | apt-key add -
apt-get update
apt-get install vmware-open-vm-tools-kmod-source
module-assistant prepare
module-assistant build vmware-open-vm-tools-kmod-source
apt-get install vmware-open-vm-tools
  • I ususaly install VMware tools from VMware supplied package and it always worked for me. I double checked that headers are of correct version but it still did not compile. Maybe it is a bug in VMware tools, since Ubuntu 11.04 is not officially supported yet. Anyway, I ended up installing the open-vm package. I think it does not require linux-headers-virtual but it makes use of linux-sources. So far I managed to install it and now testing if backup will work again. – dtoubelis Jun 22 '11 at 16:49
  • @Dmitiri I personally prefer the open-vm or vmware-open-vm packages, as you don't need to worry about the compile and you can do upgrades through Aptitude instead of recompiling stuff. What backup solution are you using that won't run without vmware tools? – pehrs Jun 22 '11 at 17:59
  • I'm using Asigra for backups and it was failing to backup this one VM after upgrade from Ubuntu 10.04 to 10.10 to 11.04. This is only Ubuntu VM I'm running, so I have nothing to compare with and VMware tools was the only error I encountered. Installing VMware tools from repository did not cure the problem, so now I'm simply using different approach for backing up this VM. – dtoubelis Jul 7 '11 at 1:54

It seems that after migration of our VMware ESXi servers to version 5.0 this problem goes away. Apparently, it was a problem with VMware tools that was eventually fixed by VMware.

Prior to this we were running VMware tools from Ubuntu repository as per @pehrs suggestion and they were working okay with exception that they were shown as "Unmanaged" in VMware vCenter and they cannot be upgraded from VMware vCenter console if new version is available. Instead, someone would need to login to the Ubuntu machine as root and check for updates. It was a working short term solution though.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.