I have some Windows virtual machines running on VMware on a Windows 2003 host, and I administer them via the Infrastructure web access.

I recently added a CentOS Linux machine as well and it was working fine until one day I tried to reboot it (this was not the first time I will be rebooting or shutting it down). It has been at "shutting down" (95%) for over a week now, unresponsive. I quickly created another installation and reinstalled my server applications and used some backups to get up and running. Now the new CentOS virtual machine is working fine but the old machine is redundant and it is still taking up space on the server.

I would love to delete this machine but I get a windows alert, "cannot delete vmware.log"; I guess because it is still shutting down. How can I force VMware to let me remove the redundant and unresponsive machine?

P.S. I cannot shut down or restart the Windows 2003 host, and the other Windows virtual machines are in continuous and active use.

1 Answer 1


Shut it down during your normal maintenance window. You install updates right?

You can try killing the right vmware-vmx.exe but I found that this screws up the user interface until you can reboot anyway.

  • Thanks. The issue is that I need that space and I can't wait for the next maintenance window. I will not be installing updates on this server for a while.
    – Cogicero
    Jun 22, 2011 at 9:26
  • I found some web resources about pressing the Alt / Command button for some seconds to allow a force-shutdown, but I tried that and it didn't work. Either it does not work for web-access, or for Windows 2003.
    – Cogicero
    Jun 22, 2011 at 9:27
  • tbh if the other VMs are vital to keep running 24/7 that you can't spare 10m for a reboot you could probably do with adding some redundancy :)
    – JamesRyan
    Jun 22, 2011 at 9:41
  • Lol no James it's not that bad. It's just that I have to schedule the downtime, and I don't have an approval on that yet. I guess I will just be patient and wait till I get that approved :) Thanks, I have accepted your answer.
    – Cogicero
    Jun 22, 2011 at 10:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .