25

I'm having some trouble creating a urlacl reservation in Windows Server 2008; probably this a rookie mistake.

The command line I'm using is:

netsh http add urlacl url=http://+:99898/ user=ben

The error that I see is:

Url reservation add failed, Error: 87
The parameter is incorrect.

There is a local user account named 'ben' that has admin privileges. I've made sure to put a trailing slash after the port number in the URL. Google and MSDN documentation are letting me down now - does anyone have any clue what I'm doing incorrectly?

3
  • Did this question make anybody think of TV crime shows with "IP addresses" like "10.68.342.12" in them? >smile< Jun 23, 2011 at 3:40
  • I'll take my lumps here... =)
    – Ben
    Jun 23, 2011 at 4:44
  • Also, as usual, if you have a user name that includes a space, use double-quotes to encapsulate it. e.g., C:\>netsh http add urlacl url=http://+:9998/ user="DOMAIN\my name"
    – lewiSnort
    Nov 14, 2018 at 1:29

3 Answers 3

12

Port number "99898" isn't a valid TCP port number. TCP port numbers are 16-bit unsigned integers, so they can't exceed 65535. I would strongly suspect that this invalid port number is the reason for the error you're seeing.

1
  • That's it - I tried with a 4-digit port number earlier, but must have gotten a different error. Thanks!
    – Ben
    Jun 23, 2011 at 0:21
53

I had the same error; in my case, the mistake I was making was omitting the trailing slash from the URL:

C:\>netsh http add urlacl url=http://+:8085 user=DOMAIN\myname
Url reservation add failed, Error: 87
The parameter is incorrect.


C:\>netsh http add urlacl url=http://+:8085/ user=DOMAIN\myname
URL reservation successfully added
1
  • And in my case, I had omitted the url= and user=, which the documentation says are optional, but are apparently not.
    – Cameron
    Jun 2, 2016 at 15:32
7
netsh http add urlacl url=https://*:8081/ user=Everyone

Also the trailing slash does matter -------------^

1
  • 1
    Could you improve the quality of your answer by pointing out why your answer is the solution?
    – John K. N.
    Oct 28, 2016 at 11:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.