I am new to AWS, so this is probably a newbie question. I have two instances, one for running a .NET Application in IIS 7.5, the other running MS SQL Server 2008 R2. I'd like the app server to get its data from the data server. I've put them both in the same security group and granted access to the standard 1433 SQL server port for the private IP addresses of both machines, as well as granted access to 1433 to the entire security group. I've also configured the "AllIPs" section to use 1433 rather than a dynamic port. I verified that TCP/IP connections as well as named pipes are permitted on the data server, and 1433 is open on both firewalls.

I've tried connecting to my data server from SSMS on the app server using the private IP as well as the private DNS name, both to no avail. In fact, I can't even ping them successfully.

What did I do wrong? Thanks!

  • 1
    If the two servers are in the same security group, they should see each other (I want to add: period). If this is not the case, something's quite wrong with your instance setup. Although I'm not familiar with win64 deployments on AWS, I can garantee you that they should see each other without any problem. Did you try disabling all FW security on the boxes ? Good Luck ! – Oct Jun 28 '11 at 21:37
  • That's not true: I can provide a few cases where this would not work. You can allow access by security group which sounds like what you're describing. – chris Dec 9 '13 at 16:05

By the assurance of @Oct that my instances should be able to talk to each other, I disabled the firewalls on both instances and tried a simple ping from App Server -> DB Server, to no avail. The problem was clearly due to my security group settings. I opened up the entire range of ports for each box, only allowable by the security group itself (basically any instance within that group). And what do you know, it worked! Ping worked, database connection worked using -private DNS name-\SQLEXPRESS. Then I re-enabled the firewalls and opened the ports that I needed to run the connection throught.

Got it all working, thanks @Oct!!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.