I'm trying to set up a template Server 2k8 R2 (Standard) VM in our VMware ESXi environment, we'll need to deploy a whole lot of them and I want to (a) streamline and (b) standardise the server build process.

Originally I built a sysprep answer file using WAIK and the Windows System Image Manager - once I'd run sysprep using this, restarting the machine resulted in a "autochk.exe not found - skipping autocheck" message, followed almost immediately by a BSOD. Rebooting just resulted in the same thing.

I first assumed it was my answer file, but have now checked this on a physical machine and it works fine.

I've reinstalled the OS on the machine (and NOTHING else), and run sysprep.exe (ticking Generalize) - this produces exactly the same result.

I've also attempted to use the Customisation Wizard built in to VMware - again, the same autocheck message and BSOD is the result.

Any ideas? Let me know any further information I need to provide...

  • What exact version of ESXi are you using and how (again as much detail as possible) is the VM defined? – Chopper3 Jun 29 '11 at 7:53
  • Grr, shouldn't have pressed [Enter]! Using ESXi 4.1 381591 (multiple hosts clustered) & VSphere 4.1 build 345043. VM has 4GB RAM, single CPU, 40GB SCSI disk, guest OS is configured as Microsoft Windows Server 2008 R2 (64-bit). Have since discovered that others have successfully used the Guest Customisation Wizard in this environment on the same server version. Must be something amiss in my VM configuration? – slag Jun 29 '11 at 22:28
  • I've done the same thing, there is a problem with using the customisation wizard with vmxnet3 vNICS to do with PCIe bus enumeration but I'm not so sure about that. You've got the latest sysprep files for R2-64? Have you tried stripping the VM of all extraneous virtual HW (floppy, cd, vNICS, set video memory auto or other settings etc.)? Got no other odd CPU mask settings for this VM? Could alway post the content of the .vmx file f you wanted, bedtime in Europe sorry though. – Chopper3 Jun 29 '11 at 22:40
  • Removed NIC, floppy, CDROM & set the video RAM to auto - same result. The only CPU mask setting is "Expose the NX/XD flag to guest", which is a default setting. The sysprep files are those that install with the OS - I can't find any newer than that. sysprep.exe file version is 6.1.7600.16385 Moved VM to a different host in the ESX cluster - same result. I'm now moving the VM to other clusters to see if the problem occurs on those. – slag Jun 29 '11 at 23:52
  • Nothing more really leaping out at me other than the usual intel/AMD thing, do you know what processors you have everywhere? Could be rubbish tbh. – Chopper3 Jun 30 '11 at 0:31

No idea at all about the cause, but creating a completely new VM from scratch (not just a reinstallation of the OS) has allowed sysprep to work.

Must have been something oddly/badly configured in the original VM, but I don't know what. Stupidly, I've deleted it so can't compare.


http://briandesmond.com/blog/how-to-sysprep-in-windows-server-2008-r2-and-windows-7/ Found the below suggestion hat worked: Boot off the windows media and choose repair (will have to go into VM bios to change boot order) to get a command prompt to do it at.

34 re: How to Sysprep in Windows Server 2008 R2 and Windows 7

Friday, April 08 2011 10:17 PM by Dan Same problem with "Autochk program not found. Skipping autocheck."

Fixed by clearing nodefaultdriveletter volume attribute via:


list volumes

select volume 1

attributes volume

attributes volume clear nodefaultdriveletter

  • Thanks Greg, if I ever come across this problem again, I'll try this. Recreating the VM from scratch worked OK for me, but if I'd alread configured a whole lot of stuff, your way would be a lot better.I'd been working through the linked article to do sysprep originally, but missed the part you quote! – slag Jul 2 '11 at 4:32

I ran into this problem after cloning an existing Windows 2008 R2 Server with VMWare vCenter when I used the VMWare customization wizard and when I used sysprep myself. Too bad vmware doesn't add this diskpart step to their customization wizard, as it would make it so much simpler.

Why build a new server from scratch when you can clone it and apply a new license?

And these instructions worked beautifully but I did notice the command should be list volume not volume***s***.

list volume
select volume 1
attributes volume
attributes volume clear nodefaultdriveletter

I had the exact same problem. But in my case it turned out to be MagicDisk (which allows .iso files to be mounted as a virtual CD) , sysprep for some reason sets the boot volume to that device so the server fails to restart. Disabled MagicDisk and problem disappeared.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.