First of all I'm running a VPS with Windows 2003 Server with IIS 6.0 and Plesk

These are the settings from php.ini max_execution_time = 300 ; Maximum execution time of each script, in seconds

The returned value is ok echo ini_get('max_execution_time'); // 300

But when I'm trying to use the keygenerator it stops executing after 30 seconds and shows Fatal error: Maximum execution time of 30 seconds exceeded in ... on line 475

The generator works just fine on a shared hosting but it doesn't work at all on my vps...

I even tried using set_time_limit(0);

Still the same.. I have FastCGI installed and the VPS is a QuadCore Xenon (with 512mb ram) so It really can't be a issue of performance


FastCGI has a limit for a request timeout in %systemroot%\system32\inetsrv\fcgiext.ini:

; RequestTimeout=n
; - Specifies the maximum allowed time, in seconds, for a request to this
;   application.  If a FastCGI process takes longer than this amount of time
;   on a single request, it will be terminated.  If not specified, the default
;   value is 90 seconds.

See if this value is set, or needs to be increased.

| improve this answer | |
  • 1
    In IIS manager (7.0), you can double click FastCGI, and then double click PHP-CGI.EXE to exit this value. After that, restart the server from IIS manager – nl-x Apr 10 '13 at 12:27
  • 1
    BTW Also check the Advanced settings of the Application Pool under which the Applications are running. – nl-x Apr 10 '13 at 12:41

There is a limit in IIS itself that dictates how long it will wait for the FastCGI processor (PHP in this case) to respond. Your PHP code (i.e. set_time_limit) will not be able to affect this.

If you have admin access on the Windows machine you will find the setting in the IIS admin console in the application configuration dialogue. IIRC the normal out-of-the-box default is 300 seconds, but it would appear that you host has turned it down.

| improve this answer | |
  • The limit in the IIS console tends to refer to ASP pages - things it processes itself, internally, rather than passing to an ISAPI filter. – crb Jun 19 '09 at 15:19

Thanks allot guys. Apparently the issue was due the script itself and the fact that it didn't work proper on php5

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.