We have a security camera system running an embedded linux. It boots with Lilo as a bootloader and has no tty access once booted. I don't know any username either.

SSH/22 is open, but I don't think brute force is an option.

I have tried all the common tricks to reset a linux user password (boot from the bootloader in single user mode = doesn't happen, still prompts for user login, boot to a live cd = can't access the file system...it's all loop files and other binary, etc etc), but they are all not possible as it is an embedded linux setup the way it is.

Any help/suggestions would be appreciated. Thanks

  • Does the manufacturer have any documentation that might help out? – Safado Jun 30 '11 at 19:19
  • What I/O ports does the camera have? What kind(s) of nonvolatile memory? – Gilles Jun 30 '11 at 19:23
  • @Ryan The Manufacturer documentation is here: docs.google.com/… and is of no help. I got contact info from the reseller we bought it from, 3 people in Taiwan who have not gotten back to me. @Gilles...the cameras come in as an old BNC to RCA AFAIK..memory..no clue...what would I be able to accomplish with that? – TryTryAgain Jun 30 '11 at 19:35
  • 1
    @TryTryAgain The point is to find a way to “get into” the camera, or at least its disk (or whatever nonvolatile memory holds the OS). Evidently you have an Ethernet connection; if there are other ports (e.g. a serial connector) you may get access that way. If you can mount the disk in another machine, you can wipe out the password from there. Unrelated note: you can only @notify one person per comment; I only saw your comment because I wandered by. – Gilles Jun 30 '11 at 21:11
  • @Gilles thanks for your help, and clarification on @replies. I do have access to mount the disk. How would I wipe the password? When I mount the disk there is no /etc/shadow or anything to access, as I stated before, only loop files and other binaries. – TryTryAgain Jun 30 '11 at 21:22

Ended up getting in to the running system command line with root access via a serial console cable. Found nowhere in documentation, but with a little Cisco, HP, etc. console cable experience, and @Gilles pointing it out, gave me enough motivation to work on it and get it done.

EDIT: Although I don't have access to the system anymore to test, I believe the method of editing the /etc/shadow would have worked out:



try that: in boot prompt enter


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.