0

The site I manage has email configured on Google Apps. So, all email accounts are there. I therefore don't want to have my local senmail accept mail for my domain. Instead, if should send it to gmail. I have put the following at the end of sendmail.mc and recompiled sendmail.cf:

define(LUSER_RELAY,`aspmx3.googlemail.com')dnl

However, I'm getting the following error still:

Jul  2 22:47:23 culinaryhalloffame sendmail[21267]: p632lNDk021267: from=apache, size=753, class=0, nrcpts=1, msgid=<13096612437327@culinarybytes.com>, relay=apache@localhost
Jul  2 22:47:23 culinaryhalloffame sendmail[21270]: p632lNkV021270: from=<apache@culinaryhalloffame.com>, size=851, class=0, nrcpts=1, msgid=<13096612437327@culinarybytes.com>, proto=ESMTP, daemon=MTA, relay=localhost [127.0.0.1]
Jul  2 22:47:23 culinaryhalloffame sendmail[21267]: p632lNDk021267: to=recluze@culinaryhalloffame.com, ctladdr=apache (48/48), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30753, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (p632lNkV021270 Message accepted for delivery)
Jul  2 22:47:24 culinaryhalloffame sendmail[21272]: STARTTLS=client, relay=aspmx3.googlemail.com., version=TLSv1/SSLv3, verify=FAIL, cipher=RC4-SHA, bits=128/128
Jul  2 22:47:27 culinaryhalloffame sendmail[21272]: p632lNkV021270: to=<recluze@culinaryhalloffame.com>, ctladdr=<apache@culinaryhalloffame.com> (48/48), delay=00:00:04, xdelay=00:00:04, mailer=relay, pri=120851, relay=aspmx3.googlemail.com. [72.14.213.27], dsn=5.1.1, stat=User unknown
Jul  2 22:47:27 culinaryhalloffame sendmail[21272]: p632lNkV021270: p632lRkV021272: DSN: User unknown
Jul  2 22:47:27 culinaryhalloffame sendmail[21272]: p632lRkV021272: to=root, delay=00:00:00, xdelay=00:00:00, mailer=local, pri=32102, dsn=2.0.0, stat=Sent

Any hints? I don't want SMTP authentication. I just want the outgoing email sent to Gmail instead of getting intercepted locally.

Thanks for the help.

2

MAIL_HUB seems better for your needs than LUSER_RELAY. You do, after all, state that all accounts are on Google Apps.

  • Thanks JdeBP. I actually figured that out after the post. For reference, the line was: define(MAIL_HUB', myhost.com.')dnl Then recompiled with: m4 /etc/mail/sendmail.mc > /etc/mail/sendmail.cf And restarted the service. – recluze Jul 5 '11 at 4:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.