0

I installed PCRE 8.12 on my server using YaST but found that PCRE 7.9 was still installed and active (as seen via pcretest -C). In order to delete or deactive PCRE 7.9 I tried deleting it using YaST. But I think that process deleted many other files which were needed for YaST to properly run. Now, YaST is broken. When I start YaST in my terminal and select+enter 'Software Management' or any other option, error like following appears:

# yast
Can't locate Config.pm in @INC (@INC contains: /y2update/modules /root/.yast2/modules /usr/share/YaST2/modules /usr/lib/perl5/site_perl/5.12.1/i586-linux-thread-multi /usr/lib/perl5/site_perl/5.12.1 /usr/lib/perl5/vendor_perl/5.12.1/i586-linux-thread-multi /usr/lib/perl5/vendor_perl/5.12.1 /usr/lib/perl5/5.12.1/i586-linux-thread-multi /usr/lib/perl5/5.12.1 .) at /usr/lib/perl5/5.12.1/diagnostics.pm line 195.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.12.1/diagnostics.pm line 195.
Compilation failed in require at /usr/lib/perl5/vendor_perl/5.12.1/i586-linux-thread-multi/YaST/YCP.pm line 119.
BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.12.1/i586-linux-thread-multi/YaST/YCP.pm line 119.
Compilation failed in require at /usr/share/YaST2/modules/URLRecode.pm line 16.
BEGIN failed--compilation aborted at /usr/share/YaST2/modules/URLRecode.pm line 16.
Compilation failed in require.
BEGIN failed--compilation aborted.
y2base: perl.c:542: perl_destruct: Assertion `(my_perl->Iscopestack_ix) == 1' failed.
YaST got signal 6 at YCP file /usr/share/YaST2/clients/sw_single.ycp:25
/sbin/yast: line 399: 30680 Aborted $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS

Following info might be useful:

I am using opensuse 11.3 (x86_64)

# zypper lr
# | Alias | Name | Enabled | Refresh
--+-------------------------------------+----------------------------------------------+---------+--------
1 | Updates for openSUSE 11.3 11.3-1.82 | Updates for openSUSE 11.3 11.3-1.82 | Yes | Yes 
2 | download.opensuse.org-oss | Main Repository (Sources) | Yes | Yes 
3 | download.opensuse.org-perl | openSUSE BuildService - devel:languageserl | Yes | Yes 
4 | download.opensuse.org-php | openSUSE BuildService - PHP | Yes | Yes 
5 | openSUSE_11.3 | openSUSE_11.3 | Yes | Yes 
6 | repo-non-oss | openSUSE-11.3-Non-Oss | Yes | Yes 
7 | repo-oss | openSUSE-11.3-Oss | Yes | Yes

I have already done zypper up

Any kind of help will be highly appreciated. Thanks...

0

Try reinstalling perl. Here is the solution of similar problems for Arch Linux

2
  • This din work for me. YaST still broken. – Usman Jul 5 '11 at 4:21
  • Installing perl-base-32bit solved the problem. :) – Usman Jul 6 '11 at 4:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.