Really having trouble with this, I've been through all the guides I can find and get stuck, using latest version of Smartermail 8 on Windows 2008 with IIS7.5.

I have it setup so I can SEND emails fine, and login etc, but it just wont RECEIVE emails. I always get this back:

Technical details of permanent failure: Google tried to deliver your message, but it was rejected by the recipient domain. We recommend contacting the other email provider for further information about the cause of this error. The error that the other server returned was: 550 550 5.7.1 Unable to relay for xxx@scirra.com (state 14).

I followed this guide:


And got these results, which make little sense to me. I've also included some images of my setup, if someone can spot the obvious fault?

enter image description here

enter image description here

enter image description here

When I do: netstat -abnp tcp

I get only one listening on port 25:


My smartermail web server config is set to all IP addresses on port 9998, I've tried 25 as well but not luck. SMTP service is stopped in services as well.

Any help greatly appreciated, I don't understand much of this.


Is this now correct? enter image description here

Update 2

MX records look like they are set up correctly. Still it's bouncing with same message.

Some people say I need to disable SMTP Service, others say leave it running. When I:

telnet 25 I get the response 220 tom.scirra.com Microsoft ESMTP MAIL Service This is with the SMTP service running.

When SMTP service is NOT running I get the response:

Could not open connection to the host, on port 25

When I netstat -abnp tcp I get TCP LISTENING [MailService.exe]


Here's what it looks like you need based upon a little digging around...

  1. You may need to update your A Record for mail.scirra.com. It looks like it is currently identifying, while it seems that your mail server is on (based upon your example/description and port scanning/direct connecting).

  2. You might also consider consider setting up a MX Record for your scirra.com domain, as there does not currently appear to be one.

Those two steps should get inbound mail flowing for your scirra.com domain if SmarterMail 8 is indeed running on

| improve this answer | |
  • Thanks! Step 2 though (please treat me like a moron), what do I put in FDQN and child domain? I'm really confused about all of this – Tom Gullen Jul 4 '11 at 23:35
  • It's actually pretty straight forward. It's basically similar to adding an A Record entry, where you call out a MX Record type instead, assigned a weight (can be anything, if there is only one MX record defined for the domain) and identify mail.scirra.com (if that is your desired incoming mail host). The mail.scirra.com just needs to be established via an A Record beforehand. It will look something like "mx 10 mail.scirra.com" (without the quotes). – user48838 Jul 5 '11 at 0:00
  • Thanks user, I updated answer, is that correct? – Tom Gullen Jul 5 '11 at 0:10
  • It looks good, but you might consider your updating SMTP "announce" or actual host name to mail.scirra.com vs. tom.scirra.com, if you are also planning to utilize the same setup for outbound SMTP as well. – user48838 Jul 5 '11 at 1:07
  • Still getting same email bounce back, how do I change my SMTP announce to mail.scirra.com? I can't see tom.scirra.com anywhere. Also, the telnet command now works fine! I think I'm getting somewhere. Under 'configure smartermail server config' it has a box which says website settings: IP-> All IP addesses | Port->9998 does port need to be 25 or is that something different? – Tom Gullen Jul 5 '11 at 15:18

I SEE WHAT YOU DID! Change that MX record from "mail" to just an empty string.

As you can see here, when I ask who handles mail for scirra.com, I get no record, but when I ask who handles mail for "mail.scirra.com" I get the right answer.

You want that MX record to just be for "scirra.com," so go and edit that record so the field labeled "Host or Child Domain" in the windows DNS manager is blank!

enter image description here

BTW, hitting mail.scirra.com on port 25 is working for me...

| improve this answer | |
  • I'm full of stupid, I really don't get this lol, thanks for your answer but I deleted my MX record and add it again, what am I putting in each box? Host or child domain should be mail right? And FQDN should be scirra.com? – Tom Gullen Jul 4 '11 at 23:16
  • Not so fast... There's a few other DNS issues lurking around here. If you ping mail.scirra.com, the response is - which is NOT in Tom's example/description! A port scan show port 25 answering up on - NOT A little bit of a mix-up... – user48838 Jul 4 '11 at 23:18
  • First, make sure that mail.scirra.com is pointing to Then, when you go to put in the MX record, you want it to look like this: i.imgur.com/26vFg.png (the part that says scirra.com. should be pre-filled) – BenGC Jul 4 '11 at 23:40
  • I update my answer, thanks for your help so far! I might need to leave it overnight to propogate though – Tom Gullen Jul 5 '11 at 0:11
  • It looks like what you did is correct! My MX check indicates that everything should be OK. Like you said, it might take some time to propagate across the internet... Oh, if my answer helped, can you do me a favor and hit that checkmark next to my post? Thanks a lot! – BenGC Jul 5 '11 at 0:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.