I am having all sorts of trouble getting SQL Server (2005) to work properly. When I run the client (SQL Server Express 2005) I get the following error "The concurrent snapshot for publication 'xx' is not available because it has not been fully generated or the Log Reader A"

The error is cropped off.

I have tried:

  • Deleting the subscription
  • Deleting the publication and starting again
  • Restarting the server and client.
  • Shrinking the database

All without any change in the result.

I know that the client can see the network share \servername\repldata which has a UNC subfolder with the snapshot in it (a folders deeper with the pubName and dateTime encoding as expected)

Any tips or trips would be REALLY appreciated!


Shrinking the database is totally orthogonal to replication - all you've done is create index fragmentation (see this SF wiki entry).

How did you setup the publication and subscription? Can you subscribe to the publication from a non-Express instance?

There seem to be lots of problems doing this - variously solved by deleting the publication database, or the subscription database, the distribution database, removing all replication and restarting, waiting for other subcriptions to sync, restarting the variosu repl agents.

In short, there doesn't seem to be a single, simple solution to this problem - even though the error really means that the snapshot hasn't completed yet. Your mileage may vary with which of these solutions works for you. Google the first part of your error message and you'll see what I mean about the variety of solutions.

Hope this is somewhat helpful.


What happens when you run the snapshot agent? Does it create the snapshot? Does it finish? Does it throw an error?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy