I have never had a problem creating a web site on this particular server until now. The server runs Server 2008, Exchange, and at least 5 other sites all with their own unique host headers tied to a single external IP. Recently, I added a new web site, redirected DNS, and added the host header to the bindings of the web site. When I try to hit it, I get a 403 forbidden error.

I then added another entry to the bindings, only this time with no host header name but using a unique port. Sure enough, after adding the firewall exception for this new port, I was able to hit the web site.

www.DOMAIN.com:8087 = Worked
www.DOMAIN.com = 403 Forbidden

The pic below is how the bindings are set up. I have tried the host header entry both with an IP specified and with a wildcard to the same effect. I checked all the directory permissions and those seem to line up. I have never seen this before so I am out of ideas.

enter image description here


Are you sure that www.domain.com pings to your 192.168.x.x IP address? I would check that at first to confirm that the DNS entry is what you expect from your testing machine.

The 403 suggests a forbidden request for some reason. Either something in your code is watching by port, or another site is catching. For example, if www.domain.com resolves to 192.168.x.y instead, then another site may be catching the traffic.

A quick test is the 'break test'. Stop the site for a few seconds and refresh. Do you still get a 403? If so, then another site is catching it. If not, then something within the site is catching it.

Also, if that site is catching it, then it's not a binding issue. It's something within the site itself. The IIS logs will show a sub-status code which can offer more clues.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.