I've installed Webmin in my server. The users of my Unix server must be able to change their passwords. So, for that, they use Usermin. But users just can't login in Usermin module. I get always this message:

Login failed. Please try again.

What is the reason for this behavior? How can I give access to Usermin to my users?

I'm able to login as any user when viewing "Current Login Sessions" -> "Switch to Usermin user:", with the Admin user.


Usermin is a separate package from Webmin; it is not a module of Webmin. So, when you want to login to Usermin, you will be doing so on a different port from Webmin (usually 20000, while Webmin is usually on 10000). So, the first possible answer, based on the confusion that Usermin is a module of Webmin, is that you're simply trying to login to the wrong place.

Webmin users are separate from system users (because it is an administrative tool, automatically granting access to it would be incredibly dangerous), and so you can't login because the user doesn't exist in Webmin. The solution is to try logging into Usermin instead of Webmin.

One tiny aside: There is a Usermin module in Webmin, but it is for the system administrator to configure Usermin. It is not Usermin. (Just like the Apache module in Webmin is not Apache, it is merely a UI for configuring it.)

OK, so assuming you're actually trying to login to Usermin and it isn't working...well, there aren't a lot of possibilities for trouble there. It is possible to configure Usermin to use PAM authentication or direct shadow file authentication. I guess it would be possible to misconfigure PAM in some way, such that logins don't work. You'd need to look in the Usermin logs to see what's happening exactly. This is usually /var/usermin/miniserv.error or another log in that directory.

Anyway, I strongly suspect your confusion over the difference between Webmin and Usermin is the issue here, but I don't have enough information to go on beyond that guess.


This occurs when you disable the shell login on Unix account creation.

Not the answer you're looking for? Browse other questions tagged or ask your own question.