I've got a couple local repositories that I can successfully access using Apache WebDav.

This apache is also a production webserver and I've got directory listings disabled globally.

Here's the Location config:

<Location /svn>
   DAV svn
   SVNParentPath /var/local/svn
   AuthType Basic
   AuthName "Dining Deals Network SVN"
   AuthUserFile /var/local/users/svn.passwd
   Require valid-user

We have 2 repo's in /var/local/svn. Right now, you have to navigate to them directly. If you just go to https://www.ourdomain.com/svn you get a

(403) Forbidden

You don't have permission to access /svn/ on this server.

I've tried adding a (and i've also tried a just for kicks) with an Options Indexes but it didn't accomplish anything.

Any help would be appreciated.


Somehow I overlooked this in the SVN WebDav documentation:


The directive is:

SVNListParentPath On|Off

When set to On, allows a GET of SVNParentPath, which results in a listing of all repositories under that path. The default setting is Off.

I knew I'd seen this working before. But GHM thanks for trying to help, you're the only one that did!


I think you cannot access ParentPath since it is not an SVN directory, so it won't match SVN permissions. What I did in order to navigate SVN repositories is to install WebSVN. I installed it by yum (for redhat/fedora) but you can use the standard installer. It's simple to install and to use, also uses the same password an auth file than SVN so you don't need any additional authentication users.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.