I'm trying to make an HP DL170 G6 server boot via the "virtual media" feature.
The system doesn't even try to boot from the virtual media, it seems unable to see it!

Here's the test we've been doing:

  • Checked correct boot order to force CD/DVD and removable drives
  • Disabled all the other boot items and tested CD/DVD and removable drives singularly
  • Checked if ISOs are bootable, tried multiple ISOs (Knoppix, Ubuntu, Damn Small Linux)
  • Successfully tried to boot from USB stick (so the ISO is good)
  • Tried different client OSes (windows XP 64, Ubuntu 10.04.2 LTS, Ubuntu 11.04)
  • Tried different Java JVM (1.4.2_19, the bare minimum)
  • Checked if the USB subsystem was enabled in BIOS
  • Removed any USB peripheral attached to the system like USB keyboards (stated as a possible problem)
  • Upgraded BIOS and iLO firmwares to the latest revisions
  • Excluded network problems (blocked ports, etc.) by connecting the iLO straight to a laptop with an Ethernet cable
  • removed vlan config from the iLO
  • Rebooted the system multiple times, cold booted the system as well
  • Tried different browsers (Opera 11.50, Firefox 4, Firefox 5, Chrome, Internet Explorer 8)
  • Checked, double checked, triple checked that the "connect" button in the virtual media applet was pressed and the ISO correctly mounted
  • Ran the browser as root

All these tests have been done and nothing succeeded so far. Anybody know what's wrong?

  • Thanks for editing Chris. Bear with me, I didn't skip English classes. I'm Italian. Regards. Commented Jul 12, 2011 at 7:00

4 Answers 4


Virtual Media tends to work decently on the LO100i devices like the one in your system. Are you licensed properly under the Application License Key Menu?

Otherwise, when you press "Connect", you should see the file path of your .ISO image change to a URL containing the IP of your client computer and connection type (e.g. /, 0, USB 2.0). If it does not do this, the .ISO will still look like it's connected, but it really isn't. When you press connect, does the IP of your client machine show up in the Virtual Media window?

HP requires that BOTH UDP and TCP port 5901 be open between the client system and the LO100i. Due to those port requirements, you may have to run the browser from an Administrator account on your PC or client system. You may also need to Connect/Disconnect several times until the IP string shows up properly like in the image below. For me it takes two tries when running as Administrator from a Windows Server 2008 client using Internet Explorer 8.

enter image description here

  • Thank you for the reply, it's been the most helpful hint I had in days. I didn't know about the ip/usb string, I couldn't find any similar instructions on hp manual. I tried from a Windows Server machine with IE8. Since I didn't have an ISO available on the machine and no access on internet, I had to try the local cd drive option. The system sees it and probably will boot! Tomorrow I'll try with an ISO and update the discussion. Thank you SO MUCH! :) Commented Jul 11, 2011 at 17:24
  • Thanks. If this is the answer, please mark it as such. Good luck!
    – ewwhite
    Commented Jul 11, 2011 at 23:56
  • It is the right answer, yes. Seems like it's a combination of closed ports / incompatible OS. As I said, I tried this with an Ubuntu 11.04 connecting straight to the server with no success. Having the ip string appear is the symptom of a successfully mounted ISO. Thank you again, you solved a big problem. Commented Jul 12, 2011 at 7:20

This feature works perfect under Linux in Firefox and Chrome/Chromium browsers with IcedTee (OpenJDK) or Oracle java plugin installed (both 32- and 64-bit OS versions).

ServerEngines' java applet installs native library libm2-32.so (or libm2-64.so respectivly) which depends on libstdc++5, but modern Linux distros does not contain this library by default. Thus, for Debian/Ubuntu you simply should install libstdc++5 package and reload webpage with java applet.

  • This was the only thing that worked for me after a great deal of messing about - I was on the same subnet with the iLO so any network blocking was right out, and no matter what I did, the system wouldn't see the virtual drive. Install the library, and no further issues. Thanks!
    – Mikey T.K.
    Commented Sep 26, 2015 at 23:10

The above answer by ewwhite is almost perfect.

What is missing here is that the virtual media feature does need a 5901 TCP/UDP connection between the server and the client, as ewwhite says, but this must be in both direction, so if your client is behind a router you need to set up a forward rule in the router for packet at port 5901 from the server (the internet) to your client.


  • you should NOT enter bios with your media device connected to avoid saving in bios the virtual CD/DVD (which would show up as DVD-QEMU something).
  • once you click "connect", the device path change name to the IP of your client not right away, but once you boot: this is why you have the feeling often that the device is not connected right away at the first time.

I also must say our configuration worked only with Windows XP and Explorer: it did not work with ubuntu and firefox.

May I also add that HP could have written a couple of note about all of this in their documentation. Anyhow I attach the part related to ports.enter image description here


Windows 2008 + IE9 worked for me, please make sure the TCP 5901 port is open explicitly in Windows firewall, both in and outbound.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .