1

Our cloud hosting company decided today to upgrade all CentOS implementations to 2.6.39.2. Unfortunately this had an adverse affect on our Apache server, preventing it from starting with mod_ssl enabled.

We're running Apache (ITK) 2.2.19 and have release 45.el5.centos.1 of the mod_ssl module installed. Both items have been reinstalled and reconfigured with the same result, when /etc/httpd/conf.d/ssl.conf is enabled, the Apache service fails to start with the only line appearing in /var/log/httpd/error_log being:

[Sun Jul 10 19:39:03 2011] [info] Init: Seeding PRNG with 256 bytes of entropy

I'm wondering if it might be something to do with the SSL certificates...and whether we might have to rebuild them from Thawte..?

Apache log level is set to debug;

# cat /etc/httpd/conf/httpd.conf | grep LogLevel
LogLevel debug

Any tips on getting more detailed logs or any hints on where to go next?!

I'm totally baffled.

0

3 Answers 3

0

One thing you can check is SELinux. I don't know exactly why, but OpenSSL 0.9.8 triggers a SELinux policy violation ("stack execute") on my Fedora machine, and it might prevent apache from starting. (I've turned SELinux into permissive mode, so I just watch the popup window without any possible consequences...)

1
  • We disabled SELinux when we set up the machine as it caused huge headaches with other things... any other ideas? (cheers for the reply!)
    – Alex
    Commented Jul 10, 2011 at 20:53
0

Thorough rebuilding of Apache & all virtual host configs finally fixed the issue. Still not 100% sure as to what the actual problem was though..! Ah well.

0
0

Update from OP:

This curious error happened again and after some more careful debugging it looks like it was down to the default "localhost" certificate being used - not sure why but Apache decided it no longer liked it and would crash when starting. A rebuild of that with genkey sorted it out & everything working again as normal!

You must log in to answer this question.