I have an HP ML330-G6 server with a single SAS/SATA drive bay unit containing a pair of mirrored 250GB SATA disks, running off a P410 SAS controller - all working fine. Now I have just fitted an Ultrium 1760 SAS tape unit into the server and I can't get both the tape and the disks recognised under VMware.

So far I have tried two SAS configurations:

  1. Disk unit on one port of the P410 + tape unit on the other port using its provided cable
  2. Disk unit + tape unit on the SAS splitter cable supplied with the tape unit - tried on port 1 and port 2 of the P410 controller

If I use the Array Configuration Utilities for the server it always shows that I have a tape unit + disks attached, but VMware stubbornly only shows the tape unit.

I have tried generic ESXi 4.1 and also the 'HP tweaked' version.

Any relevant words of wisdom appreciated. Thanks.


I'd give the Ultrium drive a dedicated 1-port internal SAS controller and skip trying to to leverage the existing P410 controller. This way, you can do passthrough SCSI to an individual VM (assuming your backup software will be running in a VM).

  • Yep, that's our bailout option. I found a thread in the VMware forums where a person's problems with a P410 went away when the tape unit was moved elsewhere. – Linker3000 Jul 11 '11 at 16:29
  • Running the tapes off of Smart Array controllers never worked well for me. In Linux, you can rescan for devices at the command line. Maybe it applies in ESXi... cyberciti.biz/faq/… – ewwhite Jul 11 '11 at 16:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.