2

We have a SQL2K8 server with a 100GB+ database that mostly stores image BLOBS and it fails to backup to our SAN that is connected over NFS. The SQL2K8 server runs off our VMWare Host and it losses network connection when this backup happens. I tend to think its a number of factors but I am learning towards the size of the database and the fact we are trying to back up a database of the size over NFS. I have done some looking around and there is nothing that stands out saying this is a bad thing but nothing that say its a good thing.

We are running compression on the database but since it is mostly compressed images it really does not make a bit of difference as far as the size goes. Has anyone run across anything like this?

2

I have discovered what the issue is, the error I am getting from SQL is stating that the network path is no longer available. This in conjunction that I have just discovered that the interface is set to 100Mbps on our QNAP device that is running SATA disks ( http://www.wdc.com/global/products/specs/?driveID=610&language=1 ) in RAID5 and the from what I have read SQL Server seems really touchy about backing up onto network drives. Here is some information I have collected that might be useful to other people that run into this problem.

Error Message

BackupIoRequest::ReportIoError: write failure on backup device ''. Operating system error 64(failed to retrieve text for this error. Reason: 15105). The operating system returned the error '64(failed to retrieve text for this error. Reason: 15105)' while attempting 'SetEndOfFile' on ''. The operating system returned the error '64(failed to retrieve text for this error. Reason: 15105)' while attempting 'FlushFileBuffers' on ''.

System Error 64 = The specified network name is no longer available http://msdn.microsoft.com/en-us/library/ms681382(v=vs.85).aspx

Here is a link to another form with people talking about this type of issue, a person posted a reg entire that I am going to try to resolve this issue as well as setting the interface to 1000Mbps http://www.sqlservercentral.com/Forums/Topic768429-391-1.aspx

I have called Microsoft on this issue and found that the following does work: kgerde open regedit navigate to: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanworkstation\parameters Create a New DWORD value with the name: SessTimeout set the value: 360 keep it Hexadecimal (This value might not work for your backup but it was high enough for mine. If this doesn't work increase the value and try again.) I hope this helps. Thanks, kgerde

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.