I publish an API on domainA.com and have done for several months. *http:/domainA.com/service.svc takes me to the resource (c:\inetput\wwwroot\api) *https://domainA.com/service.svc overnight now cannot connect the same resource.

Web site log file shows error 404 when connecting to https. Browsing to *https://domainA.com/service.svc claims the webpage is not available Log file shows successful connection when using http , log file shows 404 when using https.

The SSL certificate has been installed an working for months , several months to expiry.

I can tenet from a remote pc to domainA 80 and domainA 443 no problem so i know the firewall is fine (log files show connection).

The BINDING shows the correct ports in use 80 and 443.

The IP address ( is utilised by this web site only.

Months ago i had published a test URL on ( for testing prior to deployment but this was stopped, the new URL tested and the OLD url (website) deleted sometime ago.

Have tried restarting the problematic site.

Have tried IISreset.

I cannot understand why *https://domainA.com/service.svc overnight now cannot connect the resource the IIS BASIC settings say its pointing too. Port 443 is open and working.

In the process of checking that the IP/443 port is definitely pointing at the same resource as http reference i.e ... but log files confirm connection so it must be fine im sure.

Thank you for any help. Scott




win 2008 r2

all patched up


1 Answer 1


It was a corrupt SSL certificate. Knew it could happen but no idea what it looked like.

  • Exported the certificate
  • Deleted the installed one
  • Imported the export
  • Edited the 443 Binding on the website to select the new import
  • Stopped the site and started.
  • Site up and running again.

(reminder to always take an export backup immediately after installation)


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.