I have a single Windows 7 x64 machine that has shares running on it that I'm trying to access on the LAN. The IP of the Win7 box is on the same /24 subnet as the computers that need to access it. The machine I am trying to use to access the share is a Win 2003 x86 Standard Edition. It is also the domain controller, of which domain the Win 7 machine is a member.

When I attempt to browse the share, I go to \\win7\ or \\IP and it says "No network provider accepted the given network path.".

Steps I have taken so far:

  1. Cleared cache/flushed dns on DC as well as on Win7 box.
  2. Restarted Win7 box
  3. Verified Win7 shares are setup properly
  4. Verified I am able to browse to \\win7 from that same computer
  5. Verified I can ping the win7 box from W2k3
  6. Verified I am able to RDP from W2ke to Win7
  7. Windows Firewall is off on both machines
  8. Win7 has Symantec Endpoint Protection which, when disabled causes the same issue.
  9. Ensured that settings in Advanced Sharing Settings in Network and Sharing Center on Win 7 should be setup right for the shares to work.

I'm not really sure what else to try at this point. Anyone have any ideas? Thanks in advance!

  • Not sure if you've tried this or not but have you enabled Network Discovery on the Win7 computer? – joeqwerty Jul 13 '11 at 17:32
  • Have you tested turning UAC off? – Nixphoe Jul 13 '11 at 17:43
  • Is the LAN interface in the 'Public' location? If it is, set it to 'Work' or 'Home' and try again. – Mike Insch Jul 13 '11 at 17:43
  • Yes, network discovery is enabled, UAC is off, and the LAN interface is in the "Domain" location. – Stantonsays Jul 13 '11 at 17:54

This smells like a DNS issue. Does your Domain Controller supply DNS and DHCP for this subnet? If you are using Static IPs you will have some hostname resolution problems without a WINS server on the network.

Can you ping your win7 PC from a command prompt on the server? Watch out, Win7 blocks ICMP traffic by default, So: Turn OFF windows Firewall temporarily for the DOMAIN network profile on the Win7pc and see if you can ping it by hostname or by FQDN (hostname.domain.com) If you CAN ping by hostname it is NOT a DNS issue and I am stumped. If you can't ping the win7 machine by hostname, then examine your WINS and DNS server settings on the win7 machine (and your DHCP server).

Although you wrote "\win7" and "\IP" I hope you meant \win7 and \IP. You need two Slashes "\"

  • I am able to ping by FQDN :( Looks like Wireshark is my next step. – Stantonsays Jul 13 '11 at 18:28
  • Might double check that it's the correct NIC by checking the ARP record. Run an arp -a on the server and double check the MAC address. – Nixphoe Jul 13 '11 at 18:38
  • On a lark, please run ipconfig /all on your win7 machine and see if NetBIOS over TCPIP is ENABLED on your network connection. – GNFORCER Jul 13 '11 at 18:42
  • I verified the ARP matches, and that NetBIOS over TCPIP is enabled. I ran a Wireshark deal where I started the capture on the Win7 box, attempted to access from 2 different servers on the same switch domain/LAN, and then stopped the capture after the error came up. When I filtered the results by the IP of either server, it showed nothing at all. Seems to be something is keeping packets from reaching the Win7 box at all. They're on the same actual switch, so that's weird too. – Stantonsays Jul 13 '11 at 18:51
  • Still getting "no network provider accepted the given path"? Have you um, rebooted the win7 box? – GNFORCER Jul 13 '11 at 19:07

Can you access any other shares on the machine, such as c$? Can you access the share via ip address? Can you access the share via a local account? What are your SMB signing settings?

When all else fails, use Wireshark.

  • From the W2k3 server I can access all shares across the domain except for this machine. Regardless of what share I try to access on this machine, it doesn't allow me. I'm using domain administrator credentials. It never prompts for authentication or anything...time to fire up Wireshark! – Stantonsays Jul 13 '11 at 18:27
  • 1
    Did you check SMB signing? blogs.technet.com/b/josebda/archive/2010/12/01/… – Dave P Jul 13 '11 at 18:40
  • I haven't...I've not dealt with this before so I'm looking over it now, thanks! – Stantonsays Jul 13 '11 at 18:44
  • I checked and the Group Policy which applies to the Win7 box and the servers show that it is not defined at all. I also ran Wireshark, and as I mentioned to GNFORCER above, it didn't show any traffic at all as reaching the Win7 box from the 2 servers I tried to reach it from. – Stantonsays Jul 13 '11 at 18:53
  • Does it work in the other direction, e.g. from Win7 to domain controller? – Dave P Jul 13 '11 at 20:16

Just an off the cuff suggestion since I've been burned by it before. Check the date / time / timezone on your Windows 7 box. If that differs from your DC you could experience issues such as you've listed above. Good luck.

  • That's a good idea--I checked and they're less than 1 second in difference, though. – Stantonsays Jul 13 '11 at 18:31

this is a wins error under tcpip adapter settings. Set the wins server as the server ip Step 2 check wins is running use configure your server wizard under Administrative tools if "yes" then only do the previous step under tcpip Verson4

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.