I have a new Samba install, but it is using a config file from a previous installation of samba. This one is 3.5.6

The following is an excerpt from the config:

    workgroup = hum
    domain logons = Yes
    domain master = Yes
    local master = Yes
    os level = 65
    preferred master = Yes
    security = user

So it is a pdc, has domain name "HUM". When a user logs into the domain, their profile (created locally) has the name c:\users\[username].ZEN

"zen" is the hostname. I can happily log into the domain, and I can add machines without problems. In all cases, I refer to the domain as "HUM".

If I log into a W7 workstation as an administrator, and add a user to the administrators group, it correctly lists the user as "username" in domain "HUM".

If I then log in as that domain user (again logging into the HUM domain), I do appear to have administrator rights - I can for example run cmd as administrator.

However, weird things happen. The account cannot run control panel for example - access denied (windows cannot access the file or device). If I go to netplwiz I can see that the user in the administrators group that was previously "userid" in domain "HUM" is now "userid" in domain "ZEN".

zen is the hostname of the samba controller.

This happens on both workstations I have tried. I am wondering if the workstations previously logged into the HUM domain on a different server (it was rebuilt) and are getting messed up now they join to the same domain on the new server.

Any troubleshooting tips welcome...

  • So I removed a machine from the domain, and deleted any c:\users profiles that were domain oriented, and deleted the profiles from HKLM\Software\Microsoft\Windows NT\ProfileList. Still when I join the machine to the domain, it decides the domain is "ZEN" (the hostname) rather than "HUM" (the domain name). – Paul Jul 15 '11 at 9:35
  • In the end I gave in and renamed the domain to "zen". I still welcome any suggestions as to what was going on here. – Paul Jul 20 '11 at 3:12

In my case, the problem was that some users where created before configuring as PDC, so they referred to the host. Using pdbedit (with -I) to change the domain (and rejoining again), solved the issue

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.