I have a ESXi 3.5 server that has 3 virtual machines on there that I cannot copy/download the virtual machine OR vmdk files from.

I have tried the following options with their results:

NOTE: all virtual machines shut down with no locks

1) Under File -> Virtual Appliance -> Export Result: failed to export virtual appliance: expected FIle_data message. Got SESSION_COMPLETE

2) Through Datastore, select individual vmdk files and attempt to "download" file.
Result: failed to download file: expected FIle_data message. Got SESSION_COMPLETE

For one particular VM which has 3 drives, I can download the second, and third vmdk files, but not the main partition.
This would possibly explain why I can't export and why it fails early on in the export process.
The other 2 Virtual machines which fail with the same errors when exporting, also receive the same error when attempting to download the vmdk file.

3) Attempted to use FastSCP to copy the files and receive errors along the lines of: "Veeam FastSCP received unexpected message [4] from server...."

In general, it will get a certain way through the download/copy process. One particular will always stop at the same 3.97gb of 17gb.

I need some suggestions or solutions on how to get these vmdk files moved.

NOTE: These Virtual machines work fine and startup/shutdown without issue on the current hosting ESXi server. Also, as mentioned, during any of the above options, the virtual machines are shutdown AND there is no locks files.


  • Can you migrate them to another host? – duenni Jul 14 '11 at 14:42
  • I don't have another host (vmware product) to attempt. – pghtech Jul 14 '11 at 15:16

Ok, you could try vCenter Converter Standalone but I'm not sure if this will work, it's been a while since I used it... Another idea: Boot some imaging tool (Clonezilla or the like) inside the VM and convert the whole VM into an iso, then import it again on the host. Maybe you have some bad sectors on the host's storage or something, but otherwise you stated the machines work which is kind of confusing... I would also try to update the host to the latest version.

| improve this answer | |
  • Good suggestions, I will try them. I was going down the road of running the converter inside the VM. – pghtech Jul 14 '11 at 18:28

I solve my error Expected message put. coping one by one each file,not the entire foolder and then rigth click download and it was succesful,i hope it will help you.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.