1

The output of ec2 cli tools on my mac is nice and formatted like so:

RESERVATION     r-xxxx      xxxx    cl-xx  
INSTANCE        i-xxxx      ami-xxx                   
TAG     instance        i-xxx      Name    xxxx
etc...

On my Ubuntu machine the output is very hard to read. I followed the instructions from the Ubuntu help here: https://help.ubuntu.com/community/EC2APITools

Does anyone know what I am missing to get better looking output than this?

+------------+--------------+----------------------+------------------------------------------+---------+--------------+--------------------------
------+----------------+-------------------------------------------------------------------------------------------------+--------------+---------
----------------------------------------------------------------------------------------------------------------------+--------------------+------
| instanceId |   imageId    |    instanceState     |                  reason                  | keyName | instanceType |        launchTime        
lId   |   monitoring   |                                           stateReason                                           | architecture | rootDevi
                                           blockDeviceMapping                                                         | virtualizationType |     
+------------+--------------+----------------------+------------------------------------------+---------+--------------+--------------------------
------+----------------+-------------------------------------------------------------------------------------------------+--------------+---------
----------------------------------------------------------------------------------------------------------------------+--------------------+------
| i-xxxxxx | ami-xxxxxx | code=80 name=stopped | User initiated (2011-07-14 04:14:38 GMT) | somekey   | t1.micro     | 2011-07-14T03:46:43.000Z 
d9529 | state=disabled | code=Client.UserInitiatedShutdown message=Client.UserInitiatedShutdown: User initiated shutdown | i386         | ebs   
0

This may be a version difference. Compare the output of ec2-version on each machine.

Try downloading the EC2 API tools from http://aws.amazon.com/developertools/351 (those Ubuntu docs link to a specific version that is probably not the most recent.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.