I have setup a RRAS server on my AD machine running WS2008R2. When I set the RRAS to use a static IP pool, I can connect from my VPN just fine (I'm connecting from the built-in VPN client in Windows 7). However, when I change my RRAS to use DHCP and configure DHCP Relay Agent to forward to my D-Link router (, I get the following error in Windows 7 when I try to connect:

Error 720: A connection to the remote computer could not be established. You might need to change the network settings for this connection.

My goal was to delegate DHCP responsibilities to my router, since I don't want to install a DHCP server on this machine. Anyone have any idea what I can do to remedy this issue? Here is the corresponding error I get in my RRAS event log:

CoId={E0A1A0A2-6B0A-4B9B-B0ED-F0BE44166166}: The user DAILEY\robert connected to port VPN3-19 has been disconnected because no network protocols were successfully negotiated.

Help is greatly appreciated. If you need more information let me know and I will follow up with edits.

1 Answer 1


You shouldn't need to configure the DHCP relay agent on the RRAS server as the DHCP server on the router is on the same subnet (or should be) as the RRAS server. A DHCP relay agent is only needed when you need DHCP packets to transit a router from one subnet to another subnet. Try again with the DHCP relay agent disabled.

At the very worst you can use a static IP pool like you did previously. There's no technical reason you have to assign DHCP addresses to the VPN clients.

  • I tried using a static IP pool but the connection-specific DNS suffix is blank on clients that connect to the VPN server. I figured connecting via DHCP on my router would remedy this issue. Jul 15, 2011 at 13:23
  • The problem with using DHCP from your router is that it isn't capable of assiging a DNS suffix to the VPN clients. If you want/need to use DHCP for this purpose my suggestion would be to install the DHCP role on the server and configure it accordingly. The other thing you can do (which I just now discovered) is to assign a connection specific DNS suffix to the TCP/IP properties of the VPN connection itself. The drawback with that is that you have to manually confgure it on the VPN client. If it's just you it's no big deal but if you have other VPN users it could become a hassle.
    – joeqwerty
    Jul 15, 2011 at 19:13
  • I had the same "no network protocols were successfully negotiated" error, and your suggestion of a static IP pool solved it. Thanks also for the explanation in the comment above - you may want to move that into the answer.
    – Mike
    Oct 27, 2017 at 10:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .