I've been running a 5-drive software RAID under Windows 2003 Server. When it fails, it causes really strange problems that are difficult to deduce. After the third occurrence, I've decided to try using a Drobo instead, connected via USB2.

The Drobo drive is mapped as Z:, and has a single folder in the root called Repository, which houses all other folders and files. I've shared this folder, and added the necessary permissions. I can map a network drive letter to the Repository Share on the server and others on the network. However, it always appears to be empty (even on the Server).

Just to verify that I've used the correct approach, I've performed these same steps using a folder on the Server's C: drive, and it works correctly.

I've found a number of references to people having troubles with sharing folders on USB drives, but I didn't find any definitive solutions. (One individual suggested mapping the USB drive to a local NTFS folder, rather than as a drive letter, but the option was disabled in the drive management settings.)

Any ideas?


I haven't seen the problem you're seeing, but I have "shared" memory card readers, external USB-attached disk drives, and external firewire-attached disk drives with no ill effects in Windows Server 2003 and Windows XP. I've never used any of these Drobo devices, but if they're just a USB Mass Storage profile they should work fine.

It may be that the "Server Service" isn't "seeing" the drive. Try doing a "Restart" on that service after the drive is attached and working, and see if that improves things for you.

Adding the drive as an NTFS mount point might just change the behaviour, but I can't say for sure. I'm at a bit of a loss at this moment as to tell you why you're not able to add it as a mount point, though. (Just for kicks, I just added a FAT-formatted SD memory card in a USB reader to my Windows XP machine here with no ill effects.)

| improve this answer | |
  • I had this exact problem on Windows Server 2008 R2, and restarting the "Server" service allowed me to see the share I'd created on my USB drive. Thanks! – SqlRyan Aug 20 '10 at 0:44

One suggested solution was to mount it in an empty NTFS folder. I had originally tried this by changing the existing Z: drive letter mapping, but the "Mount in the following empty NTFS folder" option was disabled. However, when I added a second mapping, the option was available.

Once I mounted the drive in the empty NTFS folder, I was able to Share that folder, and the contents could be seen by others on the network.

I've still not determined why this didn't work when I attempted to share a folder directly on the drive-letter-mapped resource.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.