@@EDIT: Even when the Security Policies where changed to add the service account as a service account (See @Edit below) this is still not working, with the same exact problem.

I've seen this issue and I think the answer should me close to that, but seems that I can't still do this. The funny thing is the same (I think) was done by me in another server w/IIS 7 a year ago or so, without further trouble. It could be also that I don't remember so much of it. I have an Apache server running on port 80 (That can't be changed)

This is what I've done:

Integrated AppPool was an issue on the other server I've placed so I've tried to change the

  • Default AppPool to a Classic .Net
  • The WebApp Pool to a Classic .Net

The User is also mandatory on the Webservice so I'm placing a Service Account that impersonates for any anonymous (or not) user that might access so I have

  • The ServiceAccount as Administrator of wwwroot and subfolders
  • The ServiceAccount as Impersonated by default in the Default Web Site
  • The ServiceAccount as Impersonated in every Web App I need


  • I've tested the access and both Authorization & Authentication works marvelous.
  • I've restarted the app, the site and the IIS multiple times without success.
  • Checked the Event Log without finding anything useful.
  • Modified applicationHost.config getting into more troubles than solutions.

This is what I get when I try to see the App Settings at IIS7

--------------------------- Application Settings ---------------------------

There was an error while performing this operation.


Filename: \?\C:\Windows\system32\inetsrv\config\applicationHost.config

Line number: 165

Error: Can not log on locally to %SystemDrive%\inetpub\wwwroot as user MyDOMAIN\MyUser with virtual directory password

--------------------------- OK ---------------------------

This is what I see when I go to my page (an asmx)

HTTP Error 500.19 - Internal Server Error The requested page cannot be accessed because the related configuration data for the page is invalid.

Detailed Error Information Module IIS Web Core Notification Unknown Handler Not yet determined

Error Code 0x80070569

Config Error Can not log on locally to C:\inetpub\wwwroot as user MyDOMAIN\MyUser with virtual directory password

Config File Unavailable (Config Isolation)

Requested URL http://localhost:8080/myApp/MyWebService.asmx

Physical Path

Logon Method Not yet determined

Logon User Not yet determined

@EDIT: 0x80070569 Drove me to see that The service account weren't logging on as a Service (as it should), nor as a Batch process.

It was a Security Setting that should be touched, a group policy object has to be set to the account (in the Example MyDOMAIN\MyUser). And that's an access that only the area of IT Security can grant.

2 Answers 2


Set the physical path credentials Logon to The ClearText, it worked for me.


It actually was a secpol.msc Policy What was blocking the web access. The ServiceAccount wasn't a Service one.

As in the edit that I posted IT Security gave me the privileges to set it as a Service Account, but that alone just wouldn't do the trick.

In the Advanced Settings of the webSite

Physical Path Credentials Logon Type, Batch logonMethod was selected.

And the service account still wasn't with the privileges to run as a Batch Process.

And that was it.

Not only the service account, but also The Run as a Batch Job was necessary.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .