2

Following this tutorial on installing git, gitolite, git-daemon, and git-web I have successfully completed the entire tutorial and actually added projects gitolite; they show up on git web when I go to http://servername/.

Now I'm trying to clone gitolite-admin.git to add another project and it spits out the error

fatal: 'gitolite-admin.git' does not appear to be a git repository
fatal: The remote end hung up unexpectedly

I can't actually clone any repositories from my server. Here is a bit of info, although I'm not exactly sure what to provide:

  1. I can SSH to the server using SSH keys.

  2. The gitolite SSH key is working; when I execute the git clone gitolite@{server_ip}:gitolite-admin.git it asks me to enter in the passphrase for the key, which does work.

  3. sudo su gitolite while on the server allows me to cd into /home/gitolite where the repositories folder and the projects.list is held.

  4. ls in /home/gitolite/repositories shows gitolite-admin.git as well as the others.

  5. projects.list does not list gitolite-admin.git however it does list otherproject.git; if this were affecting the ability to clone, i would assume that it would still work to clone otherproject.git, which it does not.

If there is anything else I can provide to give more insight please let me know. Any help is appreciated.

Note: I followed the tutorial very closely and only strayed from their configuration at the sudo apt-get install gitolite step which is not available on Ubuntu 10.04 so I followed this article for the actual installation of gitolite.

  • serverfault.com/questions/270688/…. Please give us the content of ~/.ssh/authorized_keys? – quanta Aug 1 '11 at 7:03
  • Write the rest of the "git clone gitolite@..." command that you use to initialize cloning. – Goran Jurić Aug 1 '11 at 19:08
  • I'll have to post the authorized_keys file tomorrow morning; I'll check out that question as well. – user29600 Aug 3 '11 at 4:32
  • So you can't clone ANY repositories? – Brian Aug 4 '11 at 1:25
  • No, none of them work. – user29600 Aug 4 '11 at 4:09
0

Can you verify the value of $projectroot in /etc/gitweb.conf? It sounds like it should be /home/gitolite/repositories compared to /var/lib/gitolite/repositories in the tutorial.

What do you see when you go to http://servername/? The project list?

What about if you go directly to http://servername/gitolite-admin.git?

| improve this answer | |
0

I ended up redoing the entire installation using the installation instructions on the sitaramc.github.com website; worked first try using the root method.

Added new users following the instructions in the administration documentation.

Works from multiple client computers.

TIL; check the creator's documentation before looking for outsider tutorials.

As another note to people who may be having troubles with this... one of the errors I came across after reinstalling using the instructions above was that 'gitolite-admin' does not appear to be a git repository this ended up being because I was executing:

sudo git clone git@{SERVER_IP}:gitolite-admin

rather than

git clone git@{SERVER_IP}:gitolite-admin

which ended up using the root user to try to access the repo rather than the current user, which was already authenticated.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.