2

I installed Ubuntu 11.04 32bit as virtual machine in VMware Workstation under a 64 bit Windows7 host system. The surface of Ubuntu is Gnome, after I got a message, that Unity needs some 3D graphics...

Now I shut down my VM and enable the checkbox "Accelerate 3d Graphics" and started again. The VMware tools are also installed in the virtual machine.

Furthermore I tried the following suggestion. It didn't work either.

migrated from stackoverflow.com Jul 21 '11 at 7:46

This question came from our site for professional and enthusiast programmers.

  • Ask this on the sister-site, askubuntu.com – Jordan Parmer Jun 16 '11 at 13:24
2

VMWare won't let you use 3D graphics acceleration on non-Windows VM's as Bisti mentioned. What you can do is install the 2D version of Unity:

sudo apt-get install unity-2d-default-settings
1

Accelerate 3d Graphics is for Windows VMs only. As far as i know, you can not launch Ubuntu Unity or desktop effects on Workstation for now.

  • Not true. I am running Unity in a VMWare Workstation installation. – Michael B Jul 20 '11 at 22:46
  • @Kyle - Would you care to explain how? That is, after all, what this question is about. You would certainly get my +1 if you could actually answer the question. – Mark Booth Jul 22 '11 at 9:32
  • Wish I could tell you. I just got the same error message as you, then turned on Accelerate 3d Graphics after rebooting the machine. Works perfectly fine now. I have a GeForce 8800GT, if it matters any (I doubt it). – Michael B Jul 22 '11 at 23:07
1

The suggested fix you referenced from http://www.webupd8.org/2011/06/fix-ubuntu-linux-mint-theme-changing-to.html worked for me using VMWare Player. However... I had to extend the sleep timeout to "30". This timing value is likely hardware dependant so play around until you find the value that works for you.

Exec=bash -c "sleep 30; /usr/lib/gnome-settings-daemon/gnome-settings-daemon"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy