Usings an Asus Z8NA-D6, Xeon 5200... I believe they're on the HCL.

Attempting something similar to this: http://www.napp-it.org/doc/downloads/all-in-one.pdf

  • ESXi 4.1 U1 as hypervisor
  • Hypervisor & 1st Guest OS(Solaris Express 11) installed onto h/w RAID 1
  • Passthrough onboard SATA to 1st Guest OS
  • Create ZFS stripe/mirror array shared via NFS to ESXi

During the VMWare install it can see all the drives attached to onboard SATA.

Have followed instructions to enable passthrough - enabled VT/d for CPU and motherboard, assigned the PCI card to the Solaris guest, etc.

The Solaris guest cannot see any of the drives, if I run the Device Driver Utility it detects both controllers (2 port and 4 port) Intel 82801JI (ICH10 Family). pci-ide is the driver. I don't know how to test functionality beyond that. I can't find any trace of disks with format or in /dev/dsk

Not an expert with Solaris, so I am unsure whether this is a Solaris config issue or a VMWare issue. I'd appreciate any expertise someone could offer.

  • Device & Driver details tells me that the devfs path for one of the controllers is /pci@0,0/pci15ad,7a0@16/pci-ide@0 – Brian Jul 22 '11 at 11:25
  • If I run prtconf there are a few instances which say 'driver not attached' - useful? – Brian Jul 22 '11 at 11:28
  • Booting directly from the Solaris Express CD and I can see all drives attached to the onboard controller – Brian Jul 22 '11 at 14:38

Okay I fixed it:

The SATA Controller needs to be set to AHCI (this is done in the BIOS).

After that was set I was able to see the drives in my virtual machine.

Hopefully this might help someone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.