During setup I get several errors like the one bellow and none of the service for SQL server get installed. I did quick google search but it seems like the only solution for resolving this issue is re-installation of the whole system which is not an option. Please if you had this problem and resolved it without any drastic measures, please share it.

TITLE: Microsoft SQL Server 2008 R2 Setup

The following error has occurred:

Updating permission setting for folder 'D:\Program Files\Microsoft SQL Server\100\DTS\' failed. The folder permission setting were supposed to be set to 'D:(A;OICI;FA;;;BA)(A;OICI;FA;;;SY)(A;OICI;FA;;;CO)(A;OICI;0x1200a9;;;BU)'.

Click 'Retry' to retry the failed action, or click 'Cancel' to cancel this action and continue setup.

For help, click: http://go.microsoft.com/fwlink?LinkID=20476&ProdName=Microsoft+SQL+Server&EvtSrc=setup.rll&EvtID=50000&ProdVer=10.50.1600.1&EvtType=0xE32A4906%25400x0200CF2B

enter image description here

enter image description here

enter image description here

  • 1
    I'd be really curious to see the output of cacls /s on those directories (while the installer is sitting at the Retry box). Or you could try setting the permissions yourself w/cacls just to see what it says. I wonder how setup is doing that. Also, I wonder if the other messages (The process does not possess the SeSecurityPrivilege privilege which is required for this operation.) are at all related. Apparently seSecurityPrivilege = Manage Auditing and Security Log in the Local Security Policy > User Rights Assignment, if that helps any.
    – fission
    Jul 24, 2011 at 10:39

2 Answers 2


I'm late to the party here, I realize, but I just wandered across this after having the same problem. The comment from @fission led me to the following KB article:


The key information is here:

This behavior is by design. In addition to adding the user account that is running the setup as a local administrator as documented in How to: Install SQL Server 2008 (Setup), the setup user account requires the following default user rights for the setup to complete successfully.

Local Policy Object Display Name (User Right)

  • Backup files and directories (SeBackupPrivilege)
  • Debug Programs (SeDebugPrivilege)
  • Manage auditing and security log (SeSecurityPrivilege)

This post on MSDN forums worked for me:

I posted something on the Avast forums and got back a response that explains/solves the issue. Avast has a self-defense module that locks down permissions on the C:\Windows\Temp folder. It may lock down other folders, but I don't know that for sure.

This can be disabled. Doing so allows the installation to complete without error. To disable the Avast self-defence module:

Systray -> Right Click Avast -> Open Avast user interface -> Settings -> Troubleshooting -> Enable self-defense module.

Symantec does not cause the SQL installation to fail like Avast does. And, this problem does not happen on Windows 7.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .