0

My local network is handled using a wireless router flashed with DD-WRT. I have a wireless device on my local network whose web interface I've been exposing to the Internet via port forwarding. I setup a dynamic dns (DynDNS) entry for my local network and had been successfully routing both local and external traffic to the forwarded port via this dns name.

A recent upgrade of the router firmware broke this port forwarding. External networks can still use the dynamic dns name. Local clients using this dns name fail to route the internal device. Local traffic still routes via the local IP.

2
  • 2
    Does reverting to the previous version of DD-WRT resolve the issue? If so, it could be a bug in that particular release. It could also be that the old config didn't upgrade properly (despite what the GUI may say) – you could try to reset the config and start over.
    – fission
    Jul 25, 2011 at 2:44
  • The DD-WRT site does not have older versions of my firmware so I was not able to downgrade.
    – KevM
    Jul 25, 2011 at 15:16

2 Answers 2

2

I worked around this problem editing the router's /etc/hosts file to include the external dns name for the device. There was no web UI for this so I had to enable SSH use vi the edit the /etc/hosts file.

I realize this is not the best solution but it worked for me.

1
  • I was hoping for another enlightened answer but since you suggested.. I'll do so tomorrow when the site will allow it.
    – KevM
    Jul 26, 2011 at 0:26
0

This ticket seems to be related: http://svn.dd-wrt.com:8000/ticket/1868

They give a solution but mark the ticket as "wonfix". I do not understand why either.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.