2

I was hoping to find out how to stop windows 2008 server R2 64 bit from detecting a serial mouse on the com port. i know the boot.ini version with /noserialmouse....etc for earlier versions also i have edited the registry/services/sermouse start parameter (change from 4 to 3) to no avail. windows 2008 server has BCDedit to manage the boot options but i have not seen a reference anywhere to stop the detection of a serial mouse needless to say this server is specific to our PABX and i DO NOT HAVE a serial mouse on that port but i do have a data stream from the PABX. there is some data but it is being garbled and the application will not work.

I did manage to get it working for a few days by uninstalling the serial mouse in Dev manager, disabling and enabling the com port, but after a reboot the problem came back and now no matter what i do it will not work. i am using tools like hyperterminal and putty to view the data stream on the server and no luck. however if i connect my laptop (an XP machine) using hyperterminal the data stream is valid. assistance is greatly appreciated.

3 Answers 3

3

@h0tw1r3 has it right, but there is a typo, the registry key is "SkipEnumerations" (with an 's').

You can add this as a .reg file and import it, but you need to enable a separate entry for each port:

Windows Registry Editor Version 5.00

# Disables automatic mouse detection on boot-up on COM1
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\ACPI\PNP0501\1\Device Parameters]
"SkipEnumerations"=dword:ffffffff

#if you have more than one hard serial port, enable the following lines as needed for  each additional serial port
# for which you want to disable automatic mouse detection on boot-up
#[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\ACPI\PNP0501\2\Device Parameters]
#"SkipEnumerations"=dword:ffffffff
#
#[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\ACPI\PNP0501\3\Device Parameters]
#"SkipEnumerations"=dword:ffffffff
#
#[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\ACPI\PNP0501\4\Device Parameters]
#"SkipEnumerations"=dword:ffffffff
#

ref: http://msdn.microsoft.com/en-us/library/windows/hardware/ff546979(v=vs.85).aspx

Of course you modify the registry at your own risk!

3
  • This was already solved two months ago, the problem was with the motherboard.
    – gparent
    Commented Apr 2, 2012 at 19:07
  • Well it's a real problem and I had it this weekend. A Serial GPS connected to the computer came up as a serial mouse on bootup and locked out my GPS application. It was not easy to find the solution and the above post didn't work (but at least got me close), so I posted the corrected version. Commented Apr 3, 2012 at 3:56
  • I'm tempted to merge your answer with h0tw1r3's but since it's a few months apart I'll leave it as is and upvote it. :) Edit: I submitted an edit to the above answer to at least fix it.
    – gparent
    Commented Apr 3, 2012 at 3:57
3

First, uninstall the currently detected mouse.

If this is an on-board serial port, open regedit to the following (replace with the com port #):

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\ACPI\PNP0501\<Port#>\Device Parameters

Create a new DWORD called SkipEnumerations with a value of FFFFFFFF.

Note: If you don't have that registry key try this one

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\Root\*PNP0501\<Port#>\Device Parameters
3
  • thank you this has stopped the detection of the serial mouse however i am still not getting a clean data stream...something els is at play i am thinking....
    – Goaks
    Commented Jul 26, 2011 at 6:40
  • i have engaged MS to assist here, what we have discovered is that the serial.sys driver details are indicating a Brother Industries Ltd as the provider. we have not been able to fix this and it has been weeks. it should be MS as the provider and it could be due to this that my data is garbled. found a link that had this issue with windows 7......this was rectified by a patch...[Link]forums.mydigitallife.info/threads/…,
    – Goaks
    Commented Aug 18, 2011 at 1:47
  • Had to get Dell to swap out the MOBO. tok
    – Goaks
    Commented Jan 12, 2012 at 3:37
1

The serenum service is responsible for enumerating devices attached to a serial port. When removed from UpperFilters, the port no longer enumerates devices.

This could be an on-board port, FTDI, etc. To find the proper path, select a port in Device Manager, Properties, Details. Check the Property called Device instance path, e.g.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\ACPI\PNP0501\1
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\FTDIBUS\VID_0403+PID_6001+6&3a645483&0&6\0000
UpperFilters = serenum

I had a similar problem with an FTDI USB to serial board connected to a GPS. Fortunately under Advanced Settings there is a checkbox Serial Enumerator. When unchecked, no attempt is made to detect serial devices. This setting creates or deletes the UpperFilters key of type REG_MULTI_SZ and sets it to serenum.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .