Errors: Windows event Log - Backup started at '5/5/2011 12:34:07 AM' failed as Volume Shadow copy operation failed for backup volumes with following error code '2155348129'. Please rerun backup once issue is resolved.

The description for Event ID 24583 from source SQLWRITER cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

ICommandText::Execute 0x80040e14 SQLSTATE: 42000, Native Error: 3013 Error state: 1, Severity: 16 Source: Microsoft SQL Native Client Error message: BACKUP DATABASE is terminating abnormally.

SBS backup Error - A Volume Shadow Copy Service operation failed. Unknown error (0x800423f4).

System: SBS 2008 SP2 Running Full Backup to external HDD using Windows Server Backup.

What I've tried: - Investigated applying certain updates and hotfixes but research showed that it would not resolve the isse. http://support.microsoft.com/kb/959962.

  • Checked to see if the drive was set to auto-mount and that possibly being the reason why it wasn't detected - but my command prompt instructions informed me that it was already enabled.

  • Went through disk management to addure that there was no OEM disk partition that was active as it is also known to cause issues (no OEM active)

  • Removed the lock on the External HDD from sbs backup allowing me to run individual back-up tests on the external HDD.

  • Configured the set-up to scan once (including C and E) but the same error occurred.

  • Used Windows Backup (as opposed to SBS backup) to create a once off backup but also failed with the same error NOTE: aware that SBS Backup uses Windows server backup.

===> Ran Backup with SQL VSS writer serice stopped and full backup was successful - however if this service is stopped the backup does not contain SQL db backup. Currently running SQL 2005 at SP3 (which is updated to the latest version) ruling out possible updates to resolve the issue. May need to create Batch files to disable culprit before backup and reenable after backup but this is a work around not the solution.

  • Stopped the service SQL server VSS writer then ran Regedit. Changed the registry key to use MSDEWriter instead of SQLServerWriter.The MSDEVersionChecking value is located in the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\VSS\Settings (Value changed from 1 (uses VSSwriter) to 0 (uses MSDEwriter)). Enabled the VSS service and ran a backup on the premises that if that backup is successful whilst VSS service is running the change has worked and it is now using msde to backup the SQL DB (did not work when scheduled in, oddly enough the edited registry doesnt appear to change the primary writer from VSS to MSDE (or perhaps the presence of the service is enough to end the backup before initialization)


In cmd vssadmin list writers confirms:

Writer name: 'SqlServerWriter' Writer Id: {a65faa63-5ea8-4ebc-9dbd-a0c4db26912a} Writer Instance Id: {02638a86-5f10-480f-a994-81b7a47132f3} State: [8] Failed Last error: Non-retryable error

Dead out of ideas here to resolve this issue. Any assistance or possible solutions would be greatly appreciated.

1 Answer 1


Typically if a VSS writer is showing as failed then you will need a reboot to clear the error, though you can try a VSS reset - see http://support.microsoft.com/kb/940184 for details

The other question of course is why has this happened. In my experience the vast majority of VSS problems are caused by performance issues so things to check are:

  • Disk space
  • Fragmentation
  • Size of the volume shadow copy stores - check how much space is allocated to shadow copies and reduce this (I normally limit to 5GB if the server experiences problems but you need to consider how much data is on the server and how far back you would like to be able to recover files from)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .