I have the following set up: 1 x Windows server 2008 R2 running SQL 1 x Windows server 2008 R2 running SharePoint 2010.

I have an issue with the search service application, the crawl appears to run for a never ending amount of time with 0 successes and 0 failures. Checking the Search Application Topology, I find that "Query Component 0" is "Not Responding".

I have tried the following: I have ensured that the index directory has the right permissions applied to it and the search service account is in the right groups to consume those permissions. I have re-created the search service application. I have restarted the search service manually.

I have trawled the net as much as possible to find a solution but as of yet have not come across something that has resolved this issue.

Any input will be very much appreciated


I know this is a long time after you posted this issue.

I had the same problem on 3 different brand new 2010 farms.

The crawl components would enter the "Not Responding" state and I'd have to reboot the servers.

I finally found a soultion that worked for us.

I did an index reset just after rebooting all servers.

Waited for them to all come online in the Search Administration Topology page.

Then I set the Crawler Impact Rules to retrieve only 8 documents per request for each of my web applications.

From then on, the crawls completed without fail.

As an experiment, I set the Impact rule to retrieve 1 document per request and it failed again. Than another with 16 documents which also failed.

Left un-entered, SharePoint computes a factor to use which may be flooding your network as well as locking down your servers.

Hope this helps others.

Good luck.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.