I have a 2003 windows server as our domain controller and I am trying to upgrade the active directory to one of our new virtual machines running windows server 2008r2.

I ran through all the steps I thought I needed on the 2003 machine. Adprep /forestprep and adprep /domain prep. Went into the registry and found the entry saying that shows my active directory is on version 44 which is windows 2008r2.

At this point I logged into the new 2008 server and ran through the active directory domain services installation wizard and once I got to the part where it lists domains and I must pick one, my domain is in the list. I select that domain and click next only to receive the error...

To install a domain controller into this active directory forest, you must first prepare the forest using "adprep /forestprep". The adprep utility is available on the windows server 2008 r2 installation media in the \support\adprep folder.

I even went back into the 2003 machine and tried running all the commands again and it just comes back saying they have already been run and been upgraded.

Has anyone run into a problem like this before or know what is causing this.

  • Have you done what the error message states? Run these command on your W2K8 box instead of on the current DC. Jul 27, 2011 at 14:37
  • Tried, comes back with...."adprep cannot run on this platform because it is not an active directory domain controller."
    – Ryan Doney
    Jul 27, 2011 at 15:11
  • @Jannemans, he is receiving the error while trying to install AD on 2008, so you can't run it against the 2008 box because its not installed yet. He's already run it against the old box.
    – Kratz
    Jul 27, 2011 at 15:27
  • Found out that the problem was the media used to run adprep wasn't the r2 version of server2008. so active directory was only running version 44 instead of 47 for 2008 r2. Thanks for the help guys.
    – Ryan Doney
    Jul 28, 2011 at 12:37

2 Answers 2


Active Directory Schema Version 44 is Windows Server 2008 RTM.

If you are going to dcpromo promote a Windows Server 2008 R2 member server to a domain controller, the schema version has to be at 47 -- Windows Server 2008 R2 RTM.

Run adprep from the \support\adprep frolder on the Windows Server 2008 R2 DVD on your Windows Server 2003 domain controller with the Schema Master FSMO role.

The included version of adprep.exe on the Windows Server 2008 R2 DVD is a 64 bit executable. If your Schema Master domain controller is a 32 bit version of Windows Server, use adprep32.exe instead.


Are you running the adprep utility from the Windows 2008 R2 CD? Or are you running the one on the 2003 DC? If you just run adprep on the 2003 DC, it will run Windows 2003's adprep and not prepare the forest for 2008R2. You'll need to pop in the 2008R2 CD and run the executable on the CD.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .