2

I am trying to run the Tomcat as a service on and Windows server. If I run tomcat7.exe in the bin directory, I get the error "Service 'tomcat7' is missing the ImageFile". If I run startup.bat, tomcat opens in a new window and works just fine. Any ideas? Thanks.

2

I had the same problem, and could find a workaround. I don't know if it will work for you, though, since the OS is different (Windows Server 2008).

Steps:

  1. First delete the tomcat service with "bin\tomcat7.exe //DS/Tomcat7".

  2. Now, disable UAC.

  3. Install the Tomcat service again with the command "bin\service.bat install"

  4. Start the service.

  5. If you want (and probably will), enable UAC again.

Since I successfully installed and started the Tomcat service, I did not need to disable UAC again.

The advice to disable UAC is present Tomcat 7 documentation, located at "http://tomcat.apache.org/tomcat-7.0-doc/windows-service-howto.html"

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.