98

What is the command to sync a Windows workstation or server to its configured time source?

  • 1
    More about W32tm can be found here... technet.microsoft.com/en-us/library/bb491016.aspx – Nathan Hartley Dec 1 '16 at 16:17
  • I created a bug ticket for this. Windows fails to sync with time server upon startup, or resume from sleep or hibernation. Windows URI: feedback-hub:?contextid=58&feedbackid=f15278d4-b20d-4a9a-9693-cdf8fbaaa669&form=1&src=1 <- Place into Windows Run dialogue if you have feedback-hub installed from the windows store – Gabriel Fair Apr 14 at 13:41

10 Answers 10

95

As Kyle said w32tm /resync is the modern way to do this. See this Link to Microsoft Knowledgebase (KB 307897) for more information on the w32tm command.

There is also net time which is an older version but perhaps easier.

| improve this answer | |
  • 5
    w32tm /resync says "The computer did not resync because the required time change was too big." as my CMOS battery is dead and my computer clock resets on every boot at 1/1/2000 12:00 AM. Any help? – Never Quit Nov 4 '15 at 16:48
  • Found solution as per blog.bruteforcetech.com/archives/911 , do not forget to restart W32Time service net stop W32Time then retry w32tm /resync – Never Quit Nov 4 '15 at 17:14
  • 2
    The link is broken. – Stijn Sanders Oct 11 '17 at 9:26
  • 4
    @LightnessRacesinOrbit and the others, if you get the "time change was too big" error, use w32tm /resync /force. But if you don't have the service started, run net start w32time. Both from an elevated prompt. – cdlvcdlv May 25 '18 at 15:13
  • 4
    To solve 'time change was too big' change registry entries MaxNegPhaseCorrection and MaxPosPhaseCorrection in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time\Config to maximum (ffffffff) – Tomas F. Sep 3 '18 at 10:02
42

For those that still asking this question.

  1. To update, use the command below (2008 and 2012 server compatible)

    w32tm /config /manualpeerlist:"ntp_server" /syncfromflags:manual /reliable:yes /update
    

change the ntp_server with your source

  1. Restart the time service

    net stop w32time
    net start w32time
    
  2. Resync the time

    w32tm /resync
    
  3. Verify your sync status

    w32tm /query /status
    

Commands above should be fine if your sources are working correctly and/or your connection is OK (firewall or Microsoft Forefront can be an issue also). The commands below can help with troubleshooting

To list out peers

w32tm /query /peers

To list out NTP Sources:

w32tm /query /source
| improve this answer | |
  • Nice, comprehensive answer! Definite +1 for the command to set up the NTP server. – Shaamaan Apr 3 '17 at 9:33
  • As a note, this works for Windows 10 Professional without the "/update" flag as that is invalid. – Fmstrat Dec 4 '17 at 15:56
  • 1
    For troubleshooting, it's often useful to test the connection to a specific server: w32tm /monitor /computers:time.windows.com – Randy Orrison Mar 12 '19 at 14:44
24

You can use the following command:

w32tm /resync

| improve this answer | |
17

You can use:

w32tm /resync

Additionally, using w32tm /resync /rediscover will also "force redetection of network resourced before resynchronization."

Or using:

net time /set

Will prompt you to set the time to the DC. (Works for older versions of Windows)

| improve this answer | |
  • 3
    For some reason w32tm /resync didn't work for me but net time /SET /Y did. I used /Y for net time because it apparently doesn't read stdin properly when going through sshd from cygwin. – qwertzguy Jan 14 '15 at 3:40
  • When running w32tm /resync I got the message The computer did not resync because no time data was available. even after a service restart but net time /SET worked properly for me. – Chris Magnuson Apr 3 '17 at 12:32
3

OS: MS Windows 7

All above ideas have been tried but did not help. The original problem still exists: "The computer did not resync because the required time change was too big."

Solution is found in the registry: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\w32time\Config

  • change this if the local time is in a hurry (e.g. 31-Dec-2050): MaxNegPhaseCorrection
  • change this if the local time is delayed (e.g. 1-Jan-1980): MaxPosPhaseCorrection
  • The default values are 0xD2F0 (i.e. 54000 sec. = 15 hours)

(use Google for more details)

I use this simple win_clock_sync.bat file from Start Menu StartUp:

echo off
echo Sync computer time from internet
echo.
echo Back-up registry w32time\Config
reg export HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\w32time\Config exported_w32time.reg /y
rem changing the registry keys temporarly:
reg add HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\w32time\Config /v MaxNegPhaseCorrection /d 0xFFFFFFFF /t REG_DWORD /f
reg add HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\w32time\Config /v MaxPosPhaseCorrection /d 0xFFFFFFFF /t REG_DWORD /f
echo.
echo w32tm /config /update
w32tm /config /update
echo.
echo w32tm /resync /rediscover 
w32tm /resync /rediscover 
echo.
echo Restore registry w32time\Config
reg import exported_w32time.reg

Enjoy! :-)

| improve this answer | |
  • 1
    Your answer could use an explanation of the function of the MaxNegPhaseCorrection and MaxPosPhaseCorrection values instead of suggesting that they should be blindly disabled. That's what this script does by setting their data to 0xFFFFFFFF. – I say Reinstate Monica May 13 '17 at 18:45
  • You cannot ignore the mentioned error message "The computer did not resync because the required time change was too big." without changing the data in the MaxNegPhaseCorrection and MaxPosPhaseCorrection values. Or, did YOU find any working solution to the original problem?? And why are you writing "blindly"? If you would take a short time to read through then you could see the exporting and importing the original data of these values, what is a bit far from doing something "blindly". – Akos May 14 '17 at 7:50
  • You should have this script change the values to disabled, force an update, and then change them back to recommended values. – Cory Knutson Jun 2 '17 at 18:57
  • Twisty has valid points that do not really focus on the issue raised by NeverQuit... but then Akos has not clearly explained why the script is an appropriate solution for NeverQuit. In essence, the Registry values MaxNegPhaseCorrection and MaxPosPhaseCorrection exist to stop the W32Time service from applying dramatic changes to current time [in circumstances such as an external time source going badly awry] However, if some issue occurs that leads to a PDCe drifting rapidly from a reliable time source, then the correction controls will prevent w32tm fixing the big drift. In this situation::: b – Creaky_Uncle_Nick Jul 6 '17 at 10:32
  • @Akos Downvote retracted based on your pointing out that your script indeed does revert the changes to the MaxNegPhaseCorrection and MaxPosPhaseCorrection values. I still encourage including an explanation of what these two settings do as they're a key feature of your answer and it's important that an admin be aware that should they put these settings in place permanently they would configure their system to accept any time change, no matter how large, which could break Kerberos and other important network services. – I say Reinstate Monica Jul 7 '17 at 2:39
2

Powershell one liner if ntp server is configured:

gsv w32time | sasv; w32tm /resync /force

You can put this .bat file in the startup if you CMOS batery failed so it can resync upon OS start:

@powershell -NoProfile -Command 'gsv w32time | sasv; w32tm /resync /force'
| improve this answer | |
  • /force is not a documented command-line option for w32tm /resync. – Dai Sep 10 '18 at 20:39
1
net start w32time
w32tm /resync

According to Riot Games

| improve this answer | |
0

Almost none of the solutions (except @Akos) work if the host is an Windows Server 2016 Active Directory Domain Controller (ADDC), as it treats itself as a "reliable" source that cannot make big time change.

w32tm /resync /force does not work, because the /force does not appear in server 2016.

net time /SET /Y does not work either, because it would have asked:

Do you want to set the local computer's time to match the time at \AD.example.net? (Y/N) [Y]

Of course, it won't work if you are on AD.example.net, /Y just hides the question.

The steps work for me using PowerShell:

  1. Set w32time service as unreliable:
w32tm /config /reliable:no /syncfromflags:manual /update

Option /syncfromflags:manual means sync with NTP listed in peer list (i.e. external NTP), /update for notifying the time service the configuration have changed.

  1. Restart the w32time
Stop-Service w32time
Start-Service w32time
  1. Sync
w32tm /resync

This should work.

  1. If you DO need ADDC as a reliable time source, make it reliable again:
w32tm /config /reliable:yes /update
Stop-Service w32time
Start-Service w32time
| improve this answer | |
0

I have a Win10 image that I can restore to a snapshot where this error message is always reproducible: "The computer did not resync because the required time change was too big."

I have tried to script a solution to this problem with no avail:

reg import nettime.reg # updates MaxPosPhaseOffset and MaxNegPhaseOffset

net start w32time
w32tm.exe /config /manualpeerlist:"pool.ntp.org",0x8 /syncfromflags:manual /reliable:no /update  
w32tm.exe /query /configuration
w32tm.exe /resync /rediscover
w32tm.exe /resync /force

Neither the /reliable:no nor the MaxPosPhaseCorrection settings, nor any other commands indicated here worked immediately in a reproducible way.

After updating the registry, starting the service, updating the configuration and again restarting the service I still had to wait many minutes before I w32tm /resync /rediscover would succeed.

The time syncronization does succeed eventually, just not in a timely and reliable manner.

| improve this answer | |
-1

Try in this order. Works all the time.

w32tm /unregister

w32tm /register

net stop w32time

net start w32time

w32tm /resync
| improve this answer | |
  • I had to wait about 10 minutes between the first and second commands because of a The following error occurred: The specified service has been marked for deletion. (0x80070430) error. Then the next 3 commands worked, but the w32tm /resync command results in The computer did not resync because no time data was available. – pacoverflow May 4 at 6:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.