1

Last week we reinstalled ou AD (windows server 2008 R2), and reconfigured it (trust relationships, dns, dhcp).

There is my problem, I want to run a script to create folder remotly to a filesharing server (windows server 2003 R2 sp2), it worked fine before reinstalling the AD, but now I get this error :

Get-WmiObject: Access denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))

and the script stop.

I clueless about that, I've been looking around the web but didn't found answer. I assume it's because that the windows server 2003 denied the access from the powershell script running from the AD, but don't know how to allow the access.

If you need more accurate information, I'll gladly give them.

Thank you.

  • Please confirm: you run the script from your domain controller, which is 2008R2? And the target machine is a member server, 2003R2? Which version of powershell have you installed on the 2003R2 server? Also, how are you running the script? (e.g. scheduled task, as administrator on the DC in a console window etc.). Please also post your script. – Matt Jul 28 '11 at 11:53
  • 1
    I run the script from my ad 2008 R2, and the target is the 2003 R2. I didn't installed powershell on the 2003 R2, because with powershell 2.0 you can run command remotly without having posh install on the target. Btw I found the solution. I just forget to add the domain admin in the admin groupe of the target. Now it's work fine. Still thank you. – Anarko_Bizounours Jul 28 '11 at 13:20
1

I found the solution. I forgot to add DOMAIN\Administrator to the administrator group on the share server (target windows 2003 R2). Now that I did add it, everything work fine.

Hope this will help someone having this problem one day.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.