4

I have configured a PPTP VPN on my PFSense 2.0 RC3 router. The internet traffic comes to my modem (10.0.0.0/24) and then through my router (192.168.100.0/24).

My PPTP subnet is 192.168.101.0/24. I am able to connect to it from my IPad but then, I can only ping my PPTP server (192.168.101.1) and the LAN interface (192.168.100.1). I can't ping anything on the internet (tried 8.8.8.8) or my LAN. My iPad is connected to the Wifi access point provided by my modem, simulating an internet access.

If I check the firewall log, I can see that the ICMP packet comming from my iPad (192.168.101.100) going to 192.168.100.110 is accepted. If I do a capture from my PFSense box, I can see 192.168.100.110 received the packet and replied, but my IPad never received the answer.

The only PPTP firewall rule I have is an allow for everything from everywhere. No other rules concerning PPTP is in the LAN or WAN rules.

My knowledge of network is average but I suspect a routing problem. I know my packets go from the internet through the modem, then to the pptdp0 interface of my router, then to my machine at 192.168.100.110. I know also that my machine answer, then the traffic go to the router, by seems to stop before the pptpd0 interface as I don't see this packet in my firewall log. The firewall allow every outgoing packet from my LAN interface, so the problem should be the route between the LAN interface and the pptpd0 interface.

Can someone suggest me a solution please?

1

Allow GRE protocol as well as TCP 1723. On RC1 you didn't have to specify GRE in a rule for some reason.

0

Could it be this bug? http://redmine.pfsense.org/issues/1107

I had the same problem as you. I run pfsense 64bit on ESXi 4.1U1. VPN to LAN segment worked, but when i tried to access anything that had to go out of WAN, it wouldnt worked.

Reinstalled with 32bit version of pfsense, and imported the settings from the 64bit installation. Solved my problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.