0

I am creating my mail server and It's Continue to send/receive mails at local server through Exim, but still unable to send/receive mails from another server and show error

LOG: MAIN

<= root@ U=root P=local S=345
[root@localhost ~]# delivering 1QnnHq-0001hB-K2
T: remote_smtp for username@domainame.com
LOG: retry_defer MAIN
== username@domainname.com R=dnslookup T=remote_smtp defer (-53): retry time not reached for any host
1

That error doesn't show exactly what happened before which has deferred the message. Try running exigrep against your log files and look for the message ID (1QnnHq-0001hB-K2). That should produce some more output showing what originally went wrong.

  • when i am run command exiqgrep id .its show – user872345 Aug 1 '11 at 10:10
  • 343 1Qnoqg-000261-D5 <root@> mprabhat@gmail.com.com – user872345 Aug 1 '11 at 10:11
  • *** frozen *** $$$$$$$$$$$$$$$$$$$ – user872345 Aug 1 '11 at 11:30
  • 1
    Sorry, that should have been exigrep, my mistake. Run it as something like exigrep 1QnnHq-0001hB-K2 /var/log/exim/mainlog, replacing the last parameter with where your exim log goes. You may need to use one of the archived logs if mainlog doesn't cover the period the message originally failed to deliver. – JamesOff Aug 1 '11 at 12:14
  • Thanks this command show this error 2011-08-01 19:05:22 1QnnHq-0001hB-K2 cancelled by timeout_frozen_after 2011-08-01 19:05:22 1QnnHq-0001hB-K2 Process failed (1) when writing error message to root@ (frozen) and i am also not able to telnet with my smtp and dns... – user872345 Aug 1 '11 at 14:43
0

Have you verified that the server has a functioning DNS configuration?

  • i am able to telnet with my dns but i am not able to telnet with smtp – user872345 Aug 2 '11 at 6:34
  • From the subject server... Can it ping www.yahoo.com successfully? What is displayed when telnetting to o.mx.mail.yahoo.com at port 25 from the server? – user48838 Aug 2 '11 at 6:51
0

Frozen means that it can't go outside. Most likely I think your exim conf is set to local. Run dpkg-reconfigure exim4-config and select Internet website or with smarthost.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.