1

I'm trying to run snapshot on my server to back up the drive onto a local NAS server. I'm currently using this on a Win2k, Win2k3, and Win2k8 servers. Both the Win2k and Win2k8 servers are correctly backup up the data, but the Win2k3 is returning a:

Could not Start

error. I use a batch file to run snapshot, and it's run using a Domain Admin account. Here's the specific Batch code:

pskill snapshot
rem @echo off
echo. 2>"C:\Program Files\Snapshot\logs\monday_snapshot.log"
"C:\Program Files\Snapshot\snapshot.exe" c: \\NAS\Data_Backup\snapshot\server\monday_cdrive.sna -Go -T --novss --LogFile:"C:\Program Files\Snapshot\logs\monday_snapshot.log"
"C:\Program Files\Snapshot\snapshot.exe" F: \\NAS\Data_Backup\snapshot\server\monday_fdrive.sna -Go -T --novss --LogFile:"C:\Program Files\Snapshot\logs\monday_snapshot.log"
blat -bodyF "C:\Program Files\Snapshot\logs\monday_snapshot.log" -server mail.netcommusa.net -portSMTP 2525 -f mailrelay@netcommusa.net -i snapshot@*******.com -subject "Snapshot of Main Server" -u mailrelay@*******.net -pw mailrelay -to ********@gmail.com

Note blat is a simple program to send email from the command window

I've tried following this KB article found from this answer to a similar problem with no success. I've also tried this solution as well, but alas still no success.

My last result was:

0x0

which means that:

0x0: The operation completed successfully.

(from this KB article) but it's not successfully completing as it's not backup up the drives. Not sure where to go from here. Any suggestions?

5
  • You're running a batch file to backup? What's your batch file look like? What user are you running it from? – Nixphoe Aug 1 '11 at 20:48
  • @Nixphoe: Added more detail. – James Mertz Aug 1 '11 at 20:53
  • If you login to the server with the same user account that you're using to run the script from and you manually try to run it (maybe put in a pause at the end for troubleshooting), are you able to run it correctly? – Nixphoe Aug 1 '11 at 21:19
  • The Batch file runs fine when I run it locally. @Nixphoe – James Mertz Aug 1 '11 at 21:43
  • In the scheduled task log, what's the result code? Should be something like C0000XXX. I might also check to make sure your pskill and blat program's full path is listed just in case there might be something funny going on with that. – Nixphoe Aug 1 '11 at 21:54
0

It's definitely a security problem. You may check this by creating a simple task like cmd /c echo and seeing if it will fail, too. If it will:

  1. Check the actual value of Log on as a batch job policy (rsop.msc - Computer Configuration - Windows Settings - Security Settings - Local Policies - User Rights Assignment). If it is invalid (e. g. points to an empty group) any task will fail, even those running under the local admin account. What is more, changing the value and updating group policy won't fix this - you need to re-enter the credentials for every user sheduled tasks are running under (e. g. if you have 3 tasks running under one user and 2 tasks running under another one you need to re-enter the credentials just twice).
  2. Check ACL of %SystemRoot%\system32\cmd.exe. Read and Execute permission should be granted for BATCH group. It may be done via Group Policy: add cacls.exe %SystemRoot%\system32\cmd.exe /e /g BATCH:r to Computer Configuration - Windows Settings - Startup Scripts.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.