I have successfully joined computer to the SAMBA4 DC and successfully logging in!

Now the question is...how Linux users now can change their own passwords?

I guess it's to use "passwd" command. But it's not changing the password.

It's complaining that the password doesn't meet to requirements (trust me, I tried hard and very hard password as well as medium hard and simple, short, long...).

I think this must be done in some other way right?

This is really important...

I tried to force user to change his password on next login. The Linux (Ubuntu 11.04) is really asking for current password and asking for a new password twice. but the password, again, is not changing anyways.

Can you give me a hint?

closed as too broad by Ward, Nathan C, dawud, Scott Pack, 84104 Apr 18 '15 at 2:13

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • There's a number of methods that can be used to authenticate a Linux system against Active Directory; which are you using? – Shane Madden Aug 2 '11 at 21:27
  • I'm using through Likewise open, if I got the question right. – bakytn Aug 2 '11 at 21:32
  • @Shane, sorry I should have noticed that it's actually a SAMBA4 and not Microsoft XXXX Server's AD, this is a major notice. But may be answering to the initial question about Active Directory would help in my case too. – bakytn Aug 2 '11 at 21:33

It was due to password minimum age restriction.

You have to set this: samba-tool pwsettings set --min-pwd-age=0

Not the answer you're looking for? Browse other questions tagged or ask your own question.