3

We are trying to solve what should be a trivial problem! We have a DrayTek Vigor 2820 series ADSL router/firewall and we need to forward port 80 to a web-server.

The box is connected to it's adsl line correctly, and we can access the internet outbound.

I have a PC behind the box, running IIS with no software firewall etc... I can web browse to the pc internally, and get the IIS welcome page. The PC has no routes, and the Vigor is it's default gateway.

I have a port forward configured on the Vigor as per their instructions, to forward port 80 on the public IP address to port 80 on this internal PC.

External management of the router (which would otherwise use port 80) is disabled.

When I try to browse to the port forward via a seperate connection, the page doesn't display.

If I examine the syslog output from the vigor, I see it performing a virtual server port forward operation as I have requested, however, from running wireshark on the target PC, the request never arrives.

I have tried three different versions of firmware, as I found various reports about NAT being broken in one version or another...

Does anybody have this functionality working using one of these boxes?? I have seen several threads online saying they had problems with it, but I haven't found a solution. I can't imagine that this function is faulty in 3 versions of the o/s, so I must be missing something!!

  • Embarassingly there WAS a software firewall built into the anti-virus application which was silently preventing IIS from serving internet addresses. – JimS Aug 17 '11 at 9:25
  • Did you try upgrade a firmware? – user111989 May 23 '14 at 23:38
3

I use the same router in a few locations, where the port doesn't need to change I used NAT>Open Ports to do the same thing. I also changed the port of the management interface (even though it was disabled) to remove the possibility of a conflict.

EDIT: Also check for a software firewall on the server hosting the application :)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.