One of our Windows 2003 R2 ISA firewall servers recently had a 1-hour spell of intermittent connectivity to our Internet WAN connection, which was fixed after disabling then re-enabling the network adapter. The error log showed multiple instances of the following error:

Event 4199:
The system detected an address conflict for IP address 
with the system having network hardware address 00:00:00:00:00:00. 
Network operations on this system may be disrupted as a result

As far as I know, a null MAC address is impossible. I only found one Google result for the same error with the same strangely empty MAC address, an experts-exchange question with no answer.

The problem has not recurred, but I'm nervous having a server with unexplained issues still running as part of our live network. Without knowing the cause, I have no way of knowing that it might not happen again.

Is this a driver failure? Hardware failure? Network stack issue? Could there have been some strange conflict where something somehow tried to take over our WAN address?

  • depends on what is connected to your server, maybe some switch/router sending a spurious src mac. If there is a duplicate IP then check ARPs there maybe GRAT ARPs being transmitted too, because of the duplicate IP – user90290 Aug 4 '11 at 4:37
  • 5
    Use the RFC3330-allocated for example IP addresses. – womble Aug 4 '11 at 5:23
  • 1
    Just to be really picky, 00:00:00:00:00:00 is not null, it's just all 0's. Null would be a very serious issue. – Mark Henderson Aug 17 '11 at 1:59
  • @Mark Henderson Yes, that is a bit picky. But having a conflict with a MAC address that doesn't exist is a fairly serious issue on its own. – ryandenki Aug 19 '11 at 2:30
  • I have this same problem with IPv6 (IPv4 is just fine same machine) and it only occurred after I renamed the server. The server has been rebooted a couple of times since then, same problem. Very odd. Only TCPIP 4199 for a symptom. It has Teaming NICs though, 6 NICs to a single virtual adapter. – Mark Allen Sep 27 '11 at 19:08

It's not "impossible" - clearly it happened (for some values of "happen"). If you were able to fix it via disabling and re-enabling the network adapter in software, then my guess is that there was a low level driver software fault. It would be probably really really hard to recreate this and take it to the vendor and say 'fix this' so unfortunately you are probably going to have to chalk it up to the gremlins.

  • 1
    It certainly sounds like some sort of driver issue, although I'm very hesitant to write things off as "one of those things", although I don't see much else you can do about this one. – Mark Henderson Aug 17 '11 at 2:00
  • We definitely haven't written it off as "one of those things". We've added event log monitors to alert staff if it ever happens again, and accelerating a project to replace it with a newer package. – ryandenki Aug 19 '11 at 2:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.