Here's a problem that i've seen for the first time and unfortunatley after trying everything I still couldn't fix the issue. Any suggestions will be a great help.

The issue is that when we try to open greenworldinvestor.com it takes awful amount of time to load. The browser keeps on showing that its trying to find greenworldinvestor and when it finally finds it..it loads it in a snap.

few points -

  • earlier it was on wpwebhost and I was using godaddy to manage the dns
  • Right now its on a shared account on bluehost with nameservers pointing to bluehost
  • happens with all the browsers and on all the OS - windows, linux, mac.

Here's what i've done from my end to fix the issue ---

Although, I understand that these points are not directly related to the issue however, just to be on safe side and to avoid assumptions - i'm listing everything that i did to try and fix the issue.

  • It's on wordpress - disabled all the plugins - no luck
  • used the default wordpress theme - no luck [confirms that the issue is not with the current theme]
  • even applied a CDN - no luck {all these steps definitely improved the page load time, but again that wasn't the issue in the first place - still, i thought that it may help somehow so listed them too}

Now here are some of the results of tests on tools.pingdom.com -

  1. Full page test - here's the archived result
  2. Ping test - archived ping result [tools.pingdom.com/ping/default.aspx?target=www.greenworldinvestor.com&o=2&id=5320266]
  3. Traceroute - archived traceroute result

Dig result -

; <<>> DiG 9.6.-ESV-R4-P3 <<>> www.greenworldinvestor.com ;; global options: +cmd ;; Got answer: ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 29114 ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 2, ADDITIONAL: 0

;; QUESTION SECTION: ;www.greenworldinvestor.com. IN A

;; ANSWER SECTION: www.greenworldinvestor.com. 14400 IN CNAME greenworldinvestor.com. greenworldinvestor.com. 4311 IN A

;; AUTHORITY SECTION: greenworldinvestor.com. 162711 IN NS ns1.bluehost.com. greenworldinvestor.com. 162711 IN NS ns2.bluehost.com.

;; Query time: 67 msec ;; SERVER: ;; WHEN: Thu Aug 4 05:39:14 2011 ;; MSG SIZE rcvd: 119

Result of HTTPFox

the first byte takes 17 sec. to load... crazy!

3 Answers 3


From what I can see using the Chrome developer tools, your site is take a long time to serve the initial html of the page you request. I can say this isn't a DNS problem because, even if it were, only the first page requested would be slow. The client caches the DNS answer for a short time, so it wouldn't be slow on the second page request.

I don't know much about wordpress, but I see similar behavior from Drupal when all server-side caching is disabled. You may want to check to make sure you have caching enabled, and there is no problem with the caching module you're using.

  • nslookup confirms DNS records are responding quickly as they should.
    – JohnyD
    Aug 4, 2011 at 17:07

Not sure what may causing this, but it definitly is your main html page that is slow to load (not to render, only to load).

Your problem might come from a misconfigured PHP handler.

Could you try putting a simple HTML page (with the same content as your index page) and see if it loads faster (my guess is yes).
Then, try a simple php file (with no more than a phpinfo()) and see if it loads faster (my guess is no).

  • & @Jake Thanks guys for clearing my doubt! Indeed the issue is with php. I'm currently using w3 total cache plugin, fantastic plugin and works like a charm with most of the sites I have. it's got to do with php, .htaccess rules are correct..no issues there too. * I ran a test using HTTPFox (addon for firefox) and its result has been updated in the problem above. * I created an index.html file and it loaded instantly. so any suggestions. It's got to do with this site for sure because bluehost is supposed to work nicely with wordpress - so its not like the issue is with them.. Aug 4, 2011 at 16:58

Finally fixed the problem -

Here's what we did:

  1. It was a problem with a faulty plugin - Collapsing Categories We found that it was adding more than 300 queries and was root of the problem. Although, for some strange reason - the site was slow on the old host as well..even though that plugin wasn't active at that time.

  2. Changed the caching plugin, i noticed that somehow when w3 total cache plugin was enabled, it took time to resolve, although when we started using wp super cache plugin, it worked normally.

Anyway, it seems to be running fine now. Thanks for the support @Jake & @Pixelastic

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.