I've been trying to setup Ubuntu but have been running into countless issues. Both the 500GB drives has now become undetectable and don't even show up in BIOS. I've detailed below the process I've gone through in case it lends anyone a clue. At the start I was using a DVD with Ubuntu, at the end I'm using a USB stick (as I thought perhaps the DVD was at fault.) Both the drives are Seagate Barracuda 500GB ST3500320AS.

Drive 1

Wouldn't at first get detected in Ubuntu until I removed the jumper that was putting it in 1.5gb legacy mode.

I made it to the partition screen where I set it to have a 480GB EXT4 with a 20GB linux-swap. Before clicking next I ran fdisk -l upon which it spewed out a bunch of error messages (can't remember what they said off-hand), it then ended up erroring with a input/output error message when I clicked next.

The drive is now undetected even in BIOS. I put the jumper back in place, without any effect


Putting the disk in one of the other machines (different hardware) gave the same input/output error during read /dev/sda. After rebooting it was still detectable on the same machine.

Drive 2

Wouldn't make it to the partition part of the installation instead it would be stuck at loading (as indicated by mouse cursor), using administrative tools still worked so it wasn't simply hung.

When I looked at it having booted in with a live CD and tried to look at the disk in GParted it would get stuck at "scanning for devices". Once I managed to get past it being stuck (by specifying gparted /dev/sda). It had a 50gb unknown block (and the rest was free I think). S.M.A.R.T was saying it has 2700 faulty sectors, which seemed a bit excessive and thought it might be confused. I formatted the drive with 480GB EXT4 and 20GB linux-swap successfully. Then attempted to install getting past the partition screen and into localization setup. At about 75% of copying files it errored saying it couldn't copy a file and that it could be because the drive was faulty.

The drive is now undetectable in BIOS.


The drive worked in another machine. The machine seem think that Ubunut was already installed (after the initial botched installation). Keeps being detected after reboot. Fails at 25% with The ext4 file system creation in partition#1 of SCSI2 (0,0,0) (sda) failed.


I have attempted to switch the computer to use AHCI on a hunch that it might make it easier to detect the drives (which it didn't.)


How can I regain access to the drives to keep going on this joyous quest of failing to install Ubuntu?


I was able to install Ubuntu on a third drive (Seagate Barracuda ST3160815AS 160GB) and boot into it. I'm impressed I have two identical models that are giving different error messages.

SeaTools       Drive1   Drive2
SMART test     pass     pass
Short DST      FAIL     FAIL
Short Generic  FAIL     FAIL
Long Generic   FAIL     FAIL

SeaTools suggested I could use a DOS version to repair broken sectors, burn a CD but it wasn't able to repair them. I read (but didn't save the link) that it doesn't bother trying to repair more than a 1000 of them because we should get a new HDD after that point anyway.

Thanks for the help everyone.

  • 2
    souds like dead hardware, try a 3rd known good drive, if that fails too then its likely the motherboard, if the hard drive works, then try the other drives in another machine as they may have failed – anthonysomerset Aug 4 '11 at 12:43

Two things show that the disks are damaged

  • Disk 1: I/O errors
  • Disk 2: S.M.A.R.T detected faulty sectors

You should check them with the Seagate SeaTools diagnosis tool. First with this computer and then with another computer. If it also tells you that the drive is damaged, then throw them away or let them change by Seagate.

  • +1 for SeaTools diagnostic – Dave M Aug 4 '11 at 13:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.