2

I'm trying to VNC into a Mac OSX machine. I can ssh in fine. I am also running this VNC connection over an SSH tunnel, however it worked fine yesterday.

I'm trying

$ vncviewer 127.0.0.1::13458

and it connects and gives the following output.

Connected to RFB server, using protocol version 3.8
Performing standard VNC authentication
Password: 

I enter the VNC password. However it just hangs there and nothing happens. This happens if I enter a known incorrect password and the correct password.

What could be causing this and how would I go about diagnosing this?

1
  • did you try restarting the vnc service?
    – Simurr
    Commented Jun 22, 2009 at 16:09

2 Answers 2

4

I've had similar things happen when the ARD service went fubar and needed a restart. It's fairly simple over SSH.

If you are using a different VNC server then this still applies. Try killing the process and restarting it.

To restart the ARDAgent - http://support.apple.com/kb/HT2370

Basically.

ssh into the box and run

sudo /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/kickstart -restart -agent
2
  • Apple's VNC server is very finicky when using non-Apple VNC clients. If you leave the session open too long, or you let it time out, you will need to restart ARD.
    – moshen
    Commented Jun 22, 2009 at 17:08
  • I tried that put that didn't solve it. Commented Jun 25, 2009 at 13:44
0

I think this is my fault. I think I was confused about passwords, and was entering the wrong password. D'oh!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .