I previously had successfully set up a VPN connection that allowed my computer (Windows 7 Professional) to connect to a remote server. Last week, we had to reset our Lynksys WRT54GL wireless router, after which the VPN connection doesn't work anymore.

The problem clearly lies with the WRT54GL router: I still can establish a VPN connection with a wired connection that bypasses the router, or on my home WIFI. OTOH, when attempting either wireless or wired via the WRT54GL router, the message "port opened" is followed for a long time by "connecting to [vpn address] using WAN Miniport (PPTP)", next "connecting to [vpn address] using WAN Miniport (SSTP)", and finally "connecting to [vpn address] using WAN Miniport (L2TP)". In the end, an error code 800 is returned.

I'm no sysadmin wizard at all, and can't see what should have changed in the router configuration. Any help much appreciated, it's driving me crazy.



WRT54GL, that's a consumer router, right? Have you checked that there's a VPN passthrough option and that it's enabled?

  • Thanks for your suggestion. Yes, it has a VPN Passthrough option: all of its options (IPSec, PPTP, and L2TP Passthrough) are enabled. Tried by disabling its firewall, but that made no difference either. It's frustrating to know it has definitely worked before with this router. The only difference I see is that previously the 'DHCP Server' setting was disabled, IIRC. Still, disabling it now breaks all internet connectivity as well. Do you reckon DHCP can be a factor for VPN (apologies for my vagueness)? – rvdb Aug 9 '11 at 7:34
  • It could be if there are no ip addresses available in the DHCP pool to assign to the VPN client. It might also be that the DHCP service on the router is "competing" with an internal DHCP server. Do you have an internal DHCP server or are your internal ip addresses static? What is your VPN server? – joeqwerty Aug 9 '11 at 11:27
  • Well, the wifi router gets its IP address from another router, which is probably set up for DHCP (all computers' IP addresses are dynamic). When I connect directly to the non-wireless router, VPN works. When I connect via the wifi router (which also has a 'DHCP Server' option enabled), it doesn't. OTOH, internet connection via the wifi router apparently requires this 'DHCP Server' option, since disabling it results in 'no internet access'. Still, I recall that the DHCP option used to be switched off before the reset... – rvdb Aug 9 '11 at 11:54
  • Maybe you're confusing things a bit. There are genreally 2 DHCP settings available on a SOHO router like you have: 1. The connection type for the router has an option for the router to get it's ip address via DHCP (from the upstream network, which is the ISP), which is for the WAN port of the router. 2: The DHCP service on the router, which allows it to act as a DHCP server for clients connected on the LAN port. – joeqwerty Aug 9 '11 at 12:22
  • If the router is acting as a DHCP server for the internal clients (number 2 above) then that means that if you disable the DHCP service on the router then your clients would lose the ability to connect to the internet as they would most likely lose the DG and DNS settings that are being provided by the router. Is the DHCP pool on the router (assuming number 2 above) large enough for the LAN clients and the VPN clients? – joeqwerty Aug 9 '11 at 12:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.